Electronics > KiCad

KiCad 7.0.5 On Windows 7 - No VM - Easy!

(1/2) > >>

The Doktor:
 I know the topic of running newer versions of KiCAD on Windows 7 has come up before,  I have never seen a good solution.  Well, if anybody here is interested, I now present you with one.  As this is unsupported, you do it at your own risk, but it seems to work fine for me.

 I am not interested in a discussion about running old operating systems, nor about trashing the writers of Python or KiCAD for not supporting those older operating systems.  I know many people have strong opinions on this, and it has been discussed before. I will not be continuing those discussions on either side of the issue. This post is simply to tell you how this can be accomplished, if you have a desire to do it.

 As far as I can tell, the only thing preventing you from running  KiCAD  on Windows 7 is that  it requires a newer version of Python.  These newer versions of Python are not supported under Windows 7, and without them  KiCAD  will not run. It also requires a file which is not present in Windows 7, api-ms-win-core-path-l1-1-0.dll ( required by python as well).  I recently discovered  that some clever third parties have released  a version  oF that dll  that can be used under Windows 7, and somebody has used it to produce newer versions of Python which can also work under Windows 7.  Could my solution be this easy?  Apparently it could!

 The first thing you need to do is get a newer version of python running. I chose version 3.11.2  64-bit, as I am running a 64-bit version of Windows. If you are running 32-bit, I will let you figure out the changes you need to make.  Download the appropriate version here: https://github.com/adang1345/PythonWin7  and install it.  you need to make sure Windows knows where python is located, go to Control Panel\All Control Panel Items\System,  select "Advanced system settings",  select "Environment Variables",  and in the bottom window "System Variables"  edit the path statement so it includes  the paths to your Python installation.  On my system this is "C:\Users\Ed\AppData\Local\Programs\Python\Python311;C:\Users\USERNAME\AppData\Local\Programs\Python\Python311\Scripts;" , your paths will be different  depending on your username and whether or not you installed to the default location. You need to include the paths  for both the Python root directory and the scripts directory.  If you also have an older version of Python installed,  the new version will need to be listed before the old one in the path statement. If you have scripts that run with an older version of python, this may cause difficulty, not sure how to fix that.

 OK, hard part done.  Now we need to install KiCAD.  You cannot install KiCAD 7 on Windows 7, it will not allow it.  You can, however, install it quite easily on Windows 10. The Windows 10 you install it on should be either 32 or 64-bit to match the Windows 7 installation that you want to run on. It can be a real machine, or a virtual machine, works either way.   It can also be a Windows 10 machine you are currently running KiCAD on already.  Now that you've got it installed on a Windows 10 machine, go into the "program files" directory and copy the entire KiCAD  directory over to the Windows 7 machines "program files" directory.  There are also kICAD  directories  in the C:\Users\USERNAME\AppData\Local and C:\Users\USERNAME\AppData\Local folders, copy those as well (don't overwrite files from older KiCAD install).

One last step. You need to copy api-ms-win-core-path-l1-1-0.dll from the C:\Users\USERNAME\AppData\Local\Programs\Python\Python311 directory to C:\Program Files\KiCad\7.0\bin  or wherever your KiCAD.exe  is located.

 All done :) Double-click the KiCAD.exe  and it should run. Each time you start it, you will get a message that KiCAD  is not supported on this operating system , but it runs just fine. A few of the sub apps will give you this same message each time you open them, they also work fine. One small annoyance, you can't check which version you are running, it just says unsupported.

 If you have an older version installed, you will get the option of importing the settings. That works fine if you wish to do it. when the 7.0.6  update arrives, you will also not be able to install that on Windows 7. Just install it on Windows 10 and then copy the KiCAD  directory from program files again, that's all you need to do.

KiCAD  7 is actually running better on the Windows 7 machine then what version 5 did. It seems to be a bit more Snappy and responsive, have not had a crash yet.  If you have any problems doing this, post about it here, I will do my best to help you. No promises, but I will try.


qu1ck:
Tip: 7-zip can extract the files from the installer, this should help you skip the "install on win10" step.

1847123212:
really great solution´╝ü

krzysssztof:
Oh seriously?
I've just updated my system to run the newet KiCAD ...

Thanks for guidethrugh, though!

fionut:

Hello
Thank you for the good work
I did tried your way but..
The pcb opens , schematic does not.
_eeschema dll not found


Point to note  :I have took  the dll   by following instructions here :
https://forum.kicad.info/t/kicad-7-on-windows-7/42893 - this instructs to download python-3.9.16-embed-amd64.zip and take the dll from the archive
With this dll, kicad project files can be  opened, pcb files can be opened, schematic can not.

when I installed python, I have chosen instal python for all users ,  so my PATH system environment variable looks like :


C:\ProgramFiles(x86)\Python311-32\
C:\Program Files (x86)\Python311-32\Scripts\

After reading your post again, I have took dll from C:\Program Files (x86)\Python311-32  - which was installed by downloading the file
python-3.11.2-full.exe from the link you provided -  and put it to  kicad7.0/bin

Now nothing can be opened anymore....the application can not start correctly 0b0.. something

I have uninstalled python because that exe seemed to have installed 32 bit version;
I have downloaded 64 bit version from file python-3.11.2-amd64-full.exe ;
I have took the dll from 64 bit python folder and put it to kicad.exe folder and I put new paths to env. sys. variables
C:\Program Files\Python311\Scripts\;
C:\Program Files\Python311\;

 but now I have returned to first behaviour (can open only pcb)

I have again installed python to the default location where it wanted itself to be installed
C:\Users\work\AppData\Local\Programs\Python\Python311\

but only pcb can be opened.


Could anyone else confirm this procedure works ?


Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod