Author Topic: KiCad 7.0.6 On Windows 7 - No OS Warnings + Clickable Links, Easier Install Too!  (Read 3604 times)

0 Members and 1 Guest are viewing this topic.

Offline The DoktorTopic starter

  • Regular Contributor
  • *
  • Posts: 157
  • Country: us
I am posting this as an update to my previous post(https://www.eevblog.com/forum/kicad/kicad-7-0-5-on-windows-7-no-vm-easy!/) about running KiCad 7 on Windows 7. I am doing so for a couple of reasons. First, pretty much everything I mentioned about python is unnecessary. Python is included in KiCad, you do not need to install it. Second, I find the warning about an unsupported operating system each time you open a program rather annoying, so I fixed it. Third, well it runs perfectly after simply copying the folder, you cannot click on KiCad files to open them, and you cannot right click on a file add to always open it with KiCad. This post will show the much faster installation method, and fix all the preceding problems.

Getting KiCad running in Windows 7 without any of my enhancements is now only two or three steps, depending on whether or not you have a certain VC++ Library installed. Here it goes.

1.   Extract the files from the KiCad installer with 7-zip. You can run it from anywhere, but if you want to use my registry files the root folder should be C:\Program Files\KiCad\7.0. If you put it anywhere else you will not be able to open file simply by clicking on them.

2.   You need to add the file api-ms-win-core-path-l1-1-0.dll to the \bin directory. I have attached a file named "kicad_7.06_patch_all.zip" to this post, extract the file into the \bin directory, the dll is included in the archive. Try to open KiCad.exe. If it opens, all is good. If it complains about a missing Library, proceed to step 3.

3.   You will find a file named "VC_redist.x64.exe" in your KiCad root directory, this is the installer for the needed VC++ library. Open this file and just keep clicking okay until it is finished. KiCad should Now open and run just fine, but each time you open it you will get a message about unsupported operating system.

4.   This is an optional step, but it will probably make things nicer. There are a few files which will flash a warning about an unsupported operating system each time they are opened. These include the KiCad main file, PCB editor, schematic editor and four others. Also, the files are not registered, so you can't just click a file to open it, and windows will not allow you to right click and choose " always open with...". I have included a batch file to fix these problems. When you extracted kicad_7.06_patch_all.zip a bunch of files were created. Double click the file named "patch_all.bat", it will fix all these problems. When you run it, it will create a folder called "unpatched", copy the seven files with warning messages into this folder, and create patched version of the files back in the original location. This should end all messages about unsupported operating system. It will also run a registry file I created, which will allow project, PCB, and schematic files to be opened simply by clicking on them. As an added bonus, I assume anyone else running Windows 7 is getting sick of Google Chrome warning about unsupported operating system each time it is opened, the last two lines of my registry file fix that problem as well. If you do not wish to add the registry entries, just click no when it warns you that such entries can damage your operating system. When the batch file has completed all operations, it will delete all the files from the zip which are not needed.


That is about all there is to it, you now have a KiCad 7.06 installation which will run on Windows 7 exactly as it does on Windows 10. You can use the same installation technique and registry file I have included on any version of KiCad7.x, but the patch files will only work with 7.06. I noticed a lot of people read my previous post, and assume at least a few have actually done it. So I created this to help improve your experience. I do not wish to spam this forum, so I will not keep posting about each new version unless somebody request me to do so. But I will be continuing to run future versions of KiCad on Windows 7 as long as I can, I suspect this will carry us into v8.x and beyond, as they will be releasing it for Windows 10 as long as Microsoft supports that. And I believe any future releases that run in Windows 10 will also be runnable in Windows 7 by this method. I update my system with every new version, so I will definitely be patching future releases. If anybody is interested, it is very little additional work to release the patch files for each version.


Ed
« Last Edit: July 10, 2023, 07:28:59 pm by The Doktor »
 
The following users thanked this post: djsb, nctnico, 2nOrderEDO, edavid, PlainName, MitjaN, std

Offline fionut

  • Newbie
  • Posts: 2
  • Country: ro
Hello
Thank
This method worked for me, in Windows 7
I have tried some other methods with python..but that did not helped me opening schematics
This methods really does open pcb and schematic
I still get warning at the start of the program that this operating system is not supported by Kicad...but I can live with that
P.s. I have tried the latest kicad version 7.0.9
 

Offline eTobey

  • Regular Contributor
  • *
  • Posts: 141
  • Country: de
Hi,

its really awesome, that you are making newer versions of kicad work on windows 7.

I am wondering, why this api-ms-win-core-path-l1-1-0.dll is 100kb, when one found on some dll-website is like 3kb in size. I cant not find any code on those repos from your references, that would explain the size of it.

Isnt it just a few functions for path operations?

Cheers,
Toby
« Last Edit: November 11, 2023, 11:01:45 pm by eTobey »
 

Offline The DoktorTopic starter

  • Regular Contributor
  • *
  • Posts: 157
  • Country: us
fionut, glad you like it. If you used my patches on 7.0.9, that is why you still get the warning messages, patch is version specific.

eTobey, I don't really know anything about api-ms-win-core-path-l1-1-0.dll file except that is needed by the python version used by KiCad 7, and it is a modified version to work in Windows 7. Is it a part of Python, a Windows 10 file, or something else? I don't really know. But that file lets me run KiCad 7 and the latest version of SABnzbd on my Windows 7 machine.

Since I have 2 of you interested, I will post my updated patches for 7.0.9 shortly.
 

Offline eTobey

  • Regular Contributor
  • *
  • Posts: 141
  • Country: de
I have investigated in this dll. The link you got it from stated, that it was obtained from https://github.com/nalexandru/api-ms-win-core-path-HACK. I got the source code from that link, and compiled it, and it came out as 77Kb as compared to your 104Kb (which is in fact identical to that dll from the python package 3.11.2). I dont know why it would differ in size. I just set up Visual Studio to compile this stuff.
« Last Edit: November 12, 2023, 05:15:14 pm by eTobey »
 

Offline PlainName

  • Super Contributor
  • ***
  • Posts: 6709
  • Country: va
Quote
Since I have 2 of you interested

I would imagine many more than that. At least 3!
 

Offline The DoktorTopic starter

  • Regular Contributor
  • *
  • Posts: 157
  • Country: us
I have investigated in this dll. The link you got it from stated, that it was obtained from https://github.com/nalexandru/api-ms-win-core-path-HACK. I got the source code from that link, and compiled it, and it came out as 77Kb as compared to your 104Kb (which is in fact identical to that dll from the python package 3.11.2). I dont know why it would differ in size. I just set up Visual Studio to compile this stuff.
I added this file, to try it, if it works with this smaller size. It seems it does!

I downloaded your copy of the dll, and apparently had a copy of the 3KB as well. Tried your version and it asked for some dll I think is related to VC4. Tried it with the 3KB version and it didn't start, said didn't start correctly. My guess is the large version has the needed VC4 functions compiled into it. Your version probably works because you have the VC4 dll installed. Interestingly, I searched the entire drive on my Win 10 machine, with show hidden and system files on, and there is no api-ms-win-core-path-l1-1-0.dll anywhere, but KiCad runs fine.
 

Offline eTobey

  • Regular Contributor
  • *
  • Posts: 141
  • Country: de
I have now updated the dll. I went from Win10 SDK to Win8.1 SDK, as the project file settings would fit better then. Also i think i compiled the debug version. I found the missing *140.dll file in a debug folder, which would explain it.

Im Happy to have achieved this ;-)
« Last Edit: November 12, 2023, 08:04:29 pm by eTobey »
 

Offline eTobey

  • Regular Contributor
  • *
  • Posts: 141
  • Country: de
I just added an autohotkey script, that will close those "not supported OS" dialogs, no matter what version it is! Only works with english, but you can easily edit the file.

You have to install autohotkey, but then you can compile this to an exefile and uninstall autohotkey again. But its a nice tool, that you dont need to uninstall ;-)
« Last Edit: November 12, 2023, 08:49:09 pm by eTobey »
 
The following users thanked this post: PlainName

Offline The DoktorTopic starter

  • Regular Contributor
  • *
  • Posts: 157
  • Country: us
eTobey,I am quite familiar with autohotkey. I have scripts to let me insert special characters such as µ, or write temperatures like 70°F with just a few keystrokes,  sort certain types of files to certain folders, And even rate the ohm symbol Ω. Also use it for turning Windows functions like show file extensions were show hidden files on and off with just a keypress, and automatically move certain files to certain locations. It is quite an excellent program.

The script you wrote Works quite well, and I would assume will continue to do so even in version 8 and beyond. However, I like the patched files as they do not really flash the warning message and ending each time they are opened, I am a bit of a perfectionist that way. I will note that your script is for version 1 of autohotkey only. I tried running it through the version 1 to version 2 converter, but the converted script has a problem.The converted script closes the warning message just fine, but then it goes on and also closes KiCad. You may want to produce a script for version 2 as well. Either way, nice work.


Ed
 

Offline eTobey

  • Regular Contributor
  • *
  • Posts: 141
  • Country: de
... but then it goes on and also closes KiCad.
LOL  :-DD
Id call that a friendly fire. How in the world?

Why havent you made a script for this? Should have taken the same amout of writing you did here. Also you could test this. I stick with my version, beause i dont want the hassle like this.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf