Electronics > KiCad

KiCad install doesn't include libraries

(1/1)

Ionforbes:
Hi all,

I unsinstalled and Kicad 5 and installed Kicad 6. I checked the box to include all the default symbol and footprint libraries. When opening the symbol editor I got a popup to configure the global library tables. I think I pressed the wrong option and it kept the legacy libraries from Kicad 5. I deleted the tables in the library manager hoping it would give me the prompt again but instead just showed absoloutely nothing in the symbol editor.

The problem is, a full uninstall-reinstall doesn't fix anything! It's as if Kicad somehow 'remembers' where my old (empty) footprint table, and even though I checked the box to include all the default symbol and footprint libraries, the symbol/footprint editor is completely empty. I just don't understand why a clean install doesn't change anything; I could swear I purged my PC of anything Kicad related, including the file in Documents folder, but it stil somehow keeps the old empty library table!

Does anybody know how to fix this?
Many thanks,
Ion

retiredfeline:
A number of people have encountered similar issues, see if this thread helps:

https://forum.kicad.info/t/just-installed-v6-and-no-sysmbols-in-editor/32673

in particular this post:

https://forum.kicad.info/t/just-installed-v6-and-no-sysmbols-in-editor/32673/9

Ionforbes:
Thanks, that did it!

Credit to the guy on the kicad forum:

"I got around the issue by copying “sym-lib-table” and “fp-lib-table” from “C:\Program Files\KiCad\6.0\share\kicad\template” to “C:\Users{{USERNAME}}\AppData\Roaming\kicad\6.0”

SiliconWizard:
Yes, that happens if you select the wrong option  in the first dialog that pops up - after that, it's game over. ;D
But you can do as said above, or you can alternatively delete the whole content of the KiCad user directory (path shown above for Windows, "~/.config/kicad/6.0/" on Linux)  - next time you fire up KiCad, it will start afresh.

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version