Author Topic: KiCAD layer viewing, via stitching, and thermal relief.  (Read 5506 times)

0 Members and 1 Guest are viewing this topic.

Offline slowaudio

  • Contributor
  • Posts: 22
KiCAD layer viewing, via stitching, and thermal relief.
« on: April 14, 2014, 01:44:27 pm »
I know when using Altium, when you change your active layer, that layer appears above the other one in the graphical interface, and that layer is more prominent. Is there a way to have KiCad do the same thing? It's not helpful to have to hide the layer you don't want to see and the combination of regions that have copper on them is the awful puke green.

Via stitching. If I create some stitches (go to a pour region, start a track, press V, press End, which is what has been the most recommended method I've seen) everything appears to be fine. I then run a DRC and then the editor disconnects all my vias from the pour and pulls the copper back to meet the clearance requirements. Any suggestions?

Also, is there anyway you can change the thermal angle for circular pads? This isn't really the best way to connect this to the net.
 

Offline c4757p

  • Super Contributor
  • ***
  • Posts: 7805
  • Country: us
  • adieu
Re: KiCAD layer viewing, via stitching, and thermal relief.
« Reply #1 on: April 14, 2014, 02:15:57 pm »
You could try the "high contrast display mode" (on the left toolbar), that greys out inactive layers. I usually unfill zones and hide layers, though.

and the combination of regions that have copper on them is the awful puke green.

Adjust your monitor, it's yellow here. Or adjust your diet. ;)

Quote
Via stitching. If I create some stitches (go to a pour region, start a track, press V, press End, which is what has been the most recommended method I've seen) everything appears to be fine. I then run a DRC and then the editor disconnects all my vias from the pour and pulls the copper back to meet the clearance requirements. Any suggestions?

In older versions, yeah - you need to leave it connected to something, or it becomes disconnected. Newer (read: unstable) versions have "fixed" this - it still can become disconnected, but it can be reconnected instead of redrawn. (Yeah, it's f@$#ing annoying. They need to fix that, not "fix" it...)

Quote
Also, is there anyway you can change the thermal angle for circular pads?

I really wish there were. You can set the width and spacing of the spokes, but not the angle (edit pad -> Local Clearance and Settings).
« Last Edit: April 14, 2014, 02:18:41 pm by c4757p »
No longer active here - try the IRC channel if you just can't be without me :)
 

Offline scientist

  • Frequent Contributor
  • **
  • Banned!
  • Posts: 317
  • Country: 00
  • User banned.
Re: KiCAD layer viewing, via stitching, and thermal relief.
« Reply #2 on: May 12, 2014, 10:36:22 pm »
You could try rotating the pad 45° inside the module editor. That might do the trick.
 

Offline ConnorGames

  • Regular Contributor
  • *
  • Posts: 94
Re: KiCAD layer viewing, via stitching, and thermal relief.
« Reply #3 on: May 13, 2014, 02:47:12 am »
Quote
Quote
    and the combination of regions that have copper on them is the awful puke green.
Adjust your monitor, it's yellow here. Or adjust your diet. ;)
Looks kind of puke-green to me on my factory-calibrated U2713HM. Maybe my eyeballs need calibration. Do they still use trimpots, or is it all done in software nowdays :-DD
 

Offline chicken

  • Regular Contributor
  • *
  • Posts: 220
  • Country: us
  • Rusty Coder
Re: KiCAD layer viewing, via stitching, and thermal relief.
« Reply #4 on: May 13, 2014, 06:52:12 am »
I created a footprint for stitching-vias made up of a single through-hole pad without thermal relief. These can be easily sprinkled around the PCB without the need for a connecting track.

The only annoyance is, that I have to manually assign the pad to the GND net after pacing the footprint. Is there a way to hardcode that in the module editor?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf