EEVblog Electronics Community Forum

EDA => KiCad => Topic started by: Simon on March 03, 2011, 06:11:28 pm

Title: linking symbols to footprints in KiCAD
Post by: Simon on March 03, 2011, 06:11:28 pm
Well I'm chewing through KiCAD and have completed a board in it however I cannot get one of the parts to be included in the ratsnest. This is my LM78L05 of all parts, the symbol has pin numbers on it and so does the footprint, I've rebuilt the netlist and rerun board connectivity but nothing. I was successful on my SOT-323 parts but not the TO92, why ?
Title: Re: linking symbols to footprints in KiCAD
Post by: ElektroQuark on March 03, 2011, 07:13:15 pm
You could post the project, if you want, and I would try it.
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 03, 2011, 07:47:01 pm
might be worth a try, ultimately I need to know the solution as it looks like I'll be having a lot of this (until they get it sorted out and works more seamlessly). Which files would you need ? might be easier to email them
Title: Re: linking symbols to footprints in KiCAD
Post by: Zero999 on March 03, 2011, 09:10:28 pm
If you attach the files more people can help.

I've not done a PCB for awhile but I can't remember KiCad being that hard to use. I remember thinking last time you should give software more of a chance before giving up and I'm glad you have. Often better software with more features takes longer to learn than simple software with less features.
Title: Re: linking symbols to footprints in KiCAD
Post by: ElektroQuark on March 04, 2011, 07:47:05 am
KiCAD has an option to "archive" projects, you can use it and it will pack all of the necessary files of the project.
Title: Re: linking symbols to footprints in KiCAD
Post by: djsb on March 04, 2011, 11:35:10 am
First of all the module T0220_VERT has the pin numbers in the wrong order. Change around the position of pin 1 and pin 2 and put pin 3 where pin 1 was originally. The pin order should now be pin 1 at the top, then pin 2 then pin 3 with the tab to the right. For the schematic symbol (LM7805) VI is pin 1, GND is pin 2 and VO is pin 3. These can be edited in the library editor (pin names are set to VI, GND and VO by default). Try setting the pin names AND pin numbers to the same value. Try this and if you need more help ask away.

David.

P.S Here is the datasheet

http://www.fairchildsemi.com/ds/LM/LM7805.pdf (http://www.fairchildsemi.com/ds/LM/LM7805.pdf)
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 04, 2011, 10:09:12 pm
Yea I did have to redo the TO-220 pin numbers.

I can't set the pad names (net names) it tells me it's an unknown net name, the project files are attached, feel free to play, the part is at the bottom of the board in the middle
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 04, 2011, 10:10:53 pm
If you attach the files more people can help.

I've not done a PCB for awhile but I can't remember KiCad being that hard to use. I remember thinking last time you should give software more of a chance before giving up and I'm glad you have. Often better software with more features takes longer to learn than simple software with less features.

they have made some improvements in the later version. but this package still has some maturing to do. The autoroute function via an external service is pretty good too.
Title: Re: linking symbols to footprints in KiCAD
Post by: ElektroQuark on March 05, 2011, 07:03:59 am
You have in Eeschema: VI, Vo, GND for the pinout, and 1,2,3 in the PCB module. They must be identical, so edit the module and rename de pins to VO, VI and GND.
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 05, 2011, 07:43:22 am
Well I also have the [pins numbered in eschema so what is going on ? when I try to name the pins in PCBnew it refuses to let me do it. Are you saying I need to replace the pin numbers with pin names ?
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 05, 2011, 08:33:09 am
ok did it and it works ! good job edonork. I still can't understand though why I'm replacing pin numbers with pin names. Oh well I suppose one of those things that they need to iron out.
Title: Re: linking symbols to footprints in KiCAD
Post by: ElektroQuark on March 05, 2011, 01:05:34 pm
Well, pin names do not need to be numbers ;)
Title: Re: linking symbols to footprints in KiCAD
Post by: Simon on March 05, 2011, 01:57:18 pm
yes but in this case the field does specificly say pin num. and i went to lengths to ensure that the eschema symbol had pin numbers. Why it did this i have no idea. The thing is footprints have standardised pin number orders usually