Author Topic: Moving footprints and snapping to graphics.  (Read 2135 times)

0 Members and 1 Guest are viewing this topic.

Offline Watth

  • Regular Contributor
  • *
  • Posts: 180
  • Country: fr
Moving footprints and snapping to graphics.
« on: January 03, 2022, 02:28:23 pm »
Shouldn't a footprint snap to graphics (e.g. end of line, corner of a rectangle) when moved or dragged? Because I doesn't for me, although "Snap to graphics" is set on "Always".
Because "Matth" was already taken.
 

Offline Doctorandus_P

  • Super Contributor
  • ***
  • Posts: 2264
  • Country: nl
Re: Moving footprints and snapping to graphics.
« Reply #1 on: January 27, 2022, 12:03:24 am »
In general, graphics snap to graphics.
If you turn that off, then not even graphic lines snap to other graphic lines.

Also, if you have KiCad's PCB Editor in "High contrast mode" ("Show inactive Layers as Dimmed"), then the snap is also limited to the layer you are currently working on.

A workaround is to use a two step approach.
1. Snap the grid origin to some object.
2. Do your thing on the Grid.

It is a workaround (so not ideal) but it is usable. Setting the grid orign can be done with the S shortcut key. or, PCB Editor / Place / Grid Origin   S from the Menu.
 

Offline Watth

  • Regular Contributor
  • *
  • Posts: 180
  • Country: fr
Re: Moving footprints and snapping to graphics.
« Reply #2 on: January 27, 2022, 10:48:46 am »
I discovered that snapping graphics only works on the same layer. So indeed I have to find workarounds (such as drawing graphics on the same layer of the existing graphic, then changing the properties of the new graphic to set it on the wanted layer).
Because "Matth" was already taken.
 

Offline Bassman59

  • Super Contributor
  • ***
  • Posts: 2454
  • Country: us
  • Yes, I do this for a living
Re: Moving footprints and snapping to graphics.
« Reply #3 on: January 28, 2022, 03:47:58 pm »
Also, if you have KiCad's PCB Editor in "High contrast mode" ("Show inactive Layers as Dimmed"), then the snap is also limited to the layer you are currently working on.

Just a note for the folks playing along at home:

In Kicad 6.0.1, this mode is set by:

View -> Contrast Mode -> Inactive Layer View Mode

and a check box will appear on the menu item when that mode is enabled.

Alternatively, in the left-hand icon toolbar, it's about half-way down, looks like three traces with a via in the middle of the middle trace.

I accidentally enabled that mode and spent a few moments trying to undo it!
 
The following users thanked this post: MatthewEveritt


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf