Author Topic: PCB layout out of sync with strange "symbol association"  (Read 2367 times)

0 Members and 1 Guest are viewing this topic.

Offline prasimixTopic starter

  • Supporter
  • ****
  • Posts: 2023
  • Country: hr
    • EEZ
PCB layout out of sync with strange "symbol association"
« on: November 09, 2023, 06:55:32 am »
I am in the process of migrating from Eagle to KiCad and I started importing schematics and related footprints without any routing. The import was successful, I started slowly with the routing on the KiCad side and in that process it was necessary to correct the wiring of some components. This was done in the Schematics editor and "Update PCB from schematic" (F8 option) was used on the PCB editor side. In several iterations it worked correctly until yesterday at some point I started getting cryptic messages and it seems I lost sync between schematics and PCB layout. I don't know what to do next, I tried to go back several versions from the backup folder, there I can find older versions with which I could possibly continue to work, but I don't dare if I will face a similar problem in the future that I will not understand how it happened. Thanks in advance for any assistance.


Offline prasimixTopic starter

  • Supporter
  • ****
  • Posts: 2023
  • Country: hr
    • EEZ
Re: PCB layout out of sync with strange "symbol association"
« Reply #1 on: November 19, 2023, 10:06:27 am »
Just to let you know that I have solved all the problems in KiCad and I am making very good progress. I am impressed with the capabilities it has and I can say goodbye to the Eagle that can go into a well-deserved retirement.

In general, the issue is how to make an update so that the schematics and layout are synchronized. Evidently, I made a mistake with the footprints and didn't know that it is possible to make an update in both directions: from schematics to layout and vice versa. After a successful update, the problem was solved.

 
The following users thanked this post: mlloyd1

Offline liaifat85

  • Regular Contributor
  • *
  • !
  • Posts: 172
  • Country: bd
Re: PCB layout out of sync with strange "symbol association"
« Reply #2 on: December 14, 2023, 04:02:27 pm »
Thanks for sharing your update.
 
The following users thanked this post: prasimix


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf