Author Topic: Placing Via  (Read 18712 times)

0 Members and 1 Guest are viewing this topic.

Offline luky315

  • Regular Contributor
  • *
  • Posts: 135
  • Country: at
Placing Via
« on: July 25, 2014, 01:47:33 am »
How can I place a via in Kicad (newest "production" Version)?
I want to stitch the GND-Planes but haven't found how to simply place a via and assign it to a net.
 

Offline Bloch

  • Supporter
  • ****
  • Posts: 440
  • Country: dk
Re: Placing Via
« Reply #1 on: July 25, 2014, 06:20:37 am »


Quote from: luky315 on Today at 01:47:33 AM
How can I place a via in Kicad (newest "production" Version)?
I want to stitch the GND-Planes but haven't found how to simply place a via and assign it to a net.



I am no expert ! but a google search did get this.

https://bugs.launchpad.net/kicad/+bug/999057

They don't seems it important ! But it is on the wishlist....
 

Offline apelly

  • Supporter
  • ****
  • Posts: 1037
  • Country: nz
Re: Placing Via
« Reply #2 on: July 25, 2014, 06:25:25 am »
Within the ground flood, start a wire, press v. done.

Via stitching is more troublesome though.
I'd rather a Google clue, link, or some theory than "do this" (generally)
 

Offline chicken

  • Regular Contributor
  • *
  • Posts: 219
  • Country: us
  • Rusty Coder
Re: Placing Via
« Reply #3 on: July 28, 2014, 12:05:00 pm »
I created a footprint that's just a through hole pad with no thermal relief. Place it on the PCB and manually set the pad's net to GND. (haven't figured out how to hard code the net in the footprint)
 

Offline HackedFridgeMagnet

  • Super Contributor
  • ***
  • Posts: 1931
  • Country: au
Re: Placing Via
« Reply #4 on: July 28, 2014, 12:46:23 pm »
I just set up the two layers for the vias. Then place a track press 'v' lay more track 'v' again etc.
There is an option somewhere that then deletes superfluous tracks.
Or you can leave the superfluous tracks, if your plane is solid copper.
 

Offline Dago

  • Frequent Contributor
  • **
  • Posts: 657
  • Country: fi
    • Electronics blog about whatever I happen to build!
Re: Placing Via
« Reply #5 on: July 28, 2014, 05:46:26 pm »
This is an annoying missing feature in kicad.

Please go to the launchpad bug report (https://bugs.launchpad.net/kicad/+bug/999057) and log in and press the green "This bug also affects me" text at the top. Maybe the devs will fix/add it faster.
Come and check my projects at http://www.dgkelectronics.com ! I also tweet as https://twitter.com/DGKelectronics
 

Offline luky315

  • Regular Contributor
  • *
  • Posts: 135
  • Country: at
Re: Placing Via
« Reply #6 on: July 29, 2014, 01:24:10 am »
Thanks. I "supported" the bug report. The other thing I miss in KiCAD is the support for rounded rectangles.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf