Electronics > KiCad

[Solved] Problem downloading/installing KiCad from main site.

(1/3) > >>

Sceptic:
Hi all,

First, I'm on Ubuntu:

--- Code: ---xxx@xxx:~$ uname -a
Linux Node1 6.5.0-15-generic #15-Ubuntu SMP PREEMPT_DYNAMIC Tue Jan  9 17:03:36 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux
--- End code ---

I'm trying to update to 7.0.10 from 7.0.7 which is found in the Ubuntu repo currently.

Second, If I do
--- Code: ---sudo add-apt-repository ppa:kicad/kicad-7.0-releases
--- End code ---
I'll get the following error/message:

--- Code: ---sh: 1: /usr/lib/linuxmint/mintSources/mintSources.py: not found
--- End code ---

I did get this problem with the 6.x.x series as well but never pursued the problem further back then.

Has anyone ran into this problem and/or found a solution for this?

This is solved; please see reply #11.

Sceptic

SiliconWizard:
Why not ask in Ubuntu's forums instead?

Benta:
Just do:

sudo apt update
sudo apt upgrade

Then you'll be on 7.0.10

shapirus:
Yeah basically external repos (PPAs) aren't needed, unless you're after the latest nightly builds. It's in standard repositories: https://packages.ubuntu.com/search?keywords=kicad&searchon=names&suite=all&section=all

retiredfeline:
The problem with the official Ubuntu repos is only older KiCad versions are available for older Ubuntu releases that still in support. For example the official repo has only v6 for Jammy, but the KiCad PPA has up to date v7 packages for Jammy.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod