Electronics > KiCad

Recent KiCad testing - paths for footprints/3D models?

(1/2) > >>

So... KiCad's PCB library system was just changed a few revisions ago, and seems to be completely undocumented... Has anybody else gotten a chance to play with this? I figured out how to import my footprint library. They've apparently done away with the traditional search path and moved to substitution variables. (And it took me a while to figure out to select Legacy, because they've changed the format. I'll get around to porting my library sooner or later...)

My problem is that I can't figure out how to bring in my 3D models. The name of each model is specified in the footprint, and before, I could just add the model directory to the search path and they would show up. Now there are no search paths. :-//

By the way, there are some interesting choices under "Plugin Type": Github, Eagle, Geda. Haven't tried the Eagle one yet, I'm not sure if it actually works or if it's just a placeholder.

I can't really answer your question but I can help you look into it.  What branch are you using?  bzr branch lp:~cern-kicad/kicad/ratsnest perhaps?  You've reminded me to get this and try out the new features.  I had to compile wxWidgets myself because the package on my distro is out of date.  I'm trying to build now but keep getting errors so it may take a while to get right.

I'm using the official testing branch, on Debian Wheezy if that matters to you, presently at revision 4598.

I run Archlinux so I have to get kicad-bzr 4190 from the AUR or build from source manually.  The stable branch is a 2013/05/18 build so I don't think it has any of the neat stuff in it yet.  Neither is building for me at the moment and I'm starting to think the toolchain is broken somehow for whatever reason.  The cern-kicad/kicad/ratsnest branch is the stuff I think that's merged from cern to be included in stable at a later date but I'm not entirely sure on that.  I was directed there by the mailing list.  When I try to build the cern branch, my compiler segfaults and I can't seem to get past that.

I build from source manually as well, because 1) it's easy and 2) I've had problems with all the .deb builds.

The official kicad/testing branch has the CERN stuff now. It looks like cern-kicad/kicad/ratsnest is defunct now, probably abandoned when the changes were merged upstream. Try the official branch.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod