Electronics > Manufacturing & Assembly

Can't remove toner....

(1/4) > >>

Toner transfer is evil, so much preparation of the board is needed for good results... Moving to photoresist which is much better. But anyway.

Here I have a few boards which have been etched, and I can't get the toner off... (New cartridge)

I've tried acetone (Used a whole tub of Nail Polish Remover (~60% acetone)), methylated spirits, white spirit and a whole load of different oven cleaners/dishwashing soap etc (doesn't harm to try...)

Using the hard side of a sponge due to using up all of my wire wool... Any ideas on how I can get this toner resist off simply? Seems to be unusually stuck right on..

Xylene may work as a solvent.

Failing that I guess you'll have to abrade it off. A dremel with a fine abrasive wheel, or maybe just some fine sandpaper?

Toner is melted plastic. You will need to try something a bit more aggressive than simple solvents. Try paintbrush cleaner or paint stripper (PolyClens or PolyStrippa in the UK). The PolyClens is milder and should be tried first. Beware though, don't use it on a populated board as it will attack many plastics and will totally dissolve polystyrene.

I use 100% acetone from a quart can and I have no problems removing toner from my boards. It just wipes right off.
I wonder if the other 40% of the 60% nail polish remover is interfering somehow.

The problem is that toner compositions vary a lot between manufacturers. It's not just 'melted plastic' - most toners contain variable proportions of wax and resin, and some recent toners are designed to melt at lower temperatures to save energy. What works for one toner brand may not work with others.

Having said that, pure acetone works well with the toner from my Samsung printer.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod