Author Topic: PCB Error - Looking for some advice...  (Read 587 times)

0 Members and 1 Guest are viewing this topic.

Offline rdbanks

  • Contributor
  • Posts: 13
  • Country: gb
PCB Error - Looking for some advice...
« on: March 25, 2019, 09:23:53 pm »
Hi all!!

Right, this is my first PCB i've had produced from JLC PCB - I used Proteus (at the request of my university) and all checked out (all tests etc) however I have an issue.

One of the vias (power) has a pad on the ground side (isolated) - this was meant to pass through the PCB and then onto the top plane (power plane - where the is a connector) however, due to not having a pad on the top side, there is no through hole plating and thus no connection from the bottom pad up through to the top plane..  |O

My question, without a bodge wire - what is the best way of fixing this? I've thought about an insert soldered through and scrapping the solder mask back (this would work) but is there any other way? I doubt the solder would flow up the pin to exposed copper under the connector.

Oh and Dave, if you ever see this, don't hate on the black solder mask... hahahaha  :box:

Cheers guys and girls!

Ryan
« Last Edit: March 25, 2019, 09:26:14 pm by rdbanks »
 

Offline ebastler

  • Super Contributor
  • ***
  • Posts: 3304
  • Country: de
Re: PCB Error - Looking for some advice...
« Reply #1 on: March 25, 2019, 09:29:31 pm »
What’s wrong with a bodge wire? You can use a black one. ;-)
 
The following users thanked this post: rdbanks

Offline rdbanks

  • Contributor
  • Posts: 13
  • Country: gb
Re: PCB Error - Looking for some advice...
« Reply #2 on: March 25, 2019, 09:33:17 pm »
haha, i think it may be the best way. For extra points might run it around the side of the board (top to bottom)   :-DD

To be fair, there is a nice pad next to it, <10mm away, it wouldn't look too bad - lessoned learned though... :D
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf