Author Topic: I messed up....  (Read 313 times)

0 Members and 1 Guest are viewing this topic.

Offline lawrence11

  • Regular Contributor
  • *
  • Posts: 116
  • Country: ca
I messed up....
« on: September 23, 2019, 04:31:43 am »
So I reflowed my first BGA in my reflow oven.

Damnit, I'm like yeah it worked... Lets just see if I got a short...WTF |O

So now, I know this is removeable with a razor blade, but should I connect the L6 or leave it connected by the internal ground rails?

Probing the bga upside down there is a short.....

I have some think wire from desoldering braid and some copper foil/tape, about .003" thick.
« Last Edit: September 23, 2019, 04:47:10 am by lawrence11 »
 

Online Berni

  • Super Contributor
  • ***
  • Posts: 2464
  • Country: si
Re: I messed up....
« Reply #1 on: September 23, 2019, 05:17:37 am »
Its connected internally anyway so don't worry. Trying to bodge wire it under the BGA just means more potential for the  bodge to short something else.
 

Offline Kean

  • Supporter
  • ****
  • Posts: 915
  • Country: au
  • Embedded systems & IT consultant
    • Kean Electronics
Re: I messed up....
« Reply #2 on: September 23, 2019, 05:40:37 am »
Its connected internally anyway so don't worry. Trying to bodge wire it under the BGA just means more potential for the  bodge to short something else.

Agreed in general, but OP should really specify what BGA part is involved.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf