Electronics > Manufacturing & Assembly

JBC DDE UI question/issue


Hi everyone,

Long time lurker, newly registered, great to be part of the community.

I just recently bought a couple of JBC DDE-2C stations - That's JBC's dual tool modular stations. I've only had them for a couple of days and so far I am very pleased with the performance and quality.

I have hit a strange issue that I was wondering if anyone else has experienced with the UI. I am missing some menu options. Namely the "Files" and "Info" in the main screen and the "Name" under Station. These options are shown in the documentation and every video I can find on youtube show.

The firmware version the stations came with is 8886777. Has the UI changed recently with these options removed and the documentation hasn't caught up? Both stations are exactly the same and they perform fine when actually using them.

Another issue, that may or may not be related is that I have tried to update to the latest firmware (DDE-C, ver: 8886784). Once I connect it via the usb stick, the station picks up a USB drive is inserted, the first time it "reads" the usb thumb drive, but then just lights up the usb icon to confirm a usb-stick is connected. There is no prompt as suggested on the documentation to install the new firmware. I tried several drives, of different capacities, from 16 to 64Gb, formatted as FAT32 and FAT, and with the entire .zip, as well as the unzipped firmware in it. No luck.

Some photos of the current version and UI options attached attached.

Any suggestions welcome!


I have the same DDE(-2C) station for about 1 year, my one came with FW 8886566.

Unlike yours, I don't miss any menu options, but I also want to install the most recent FW 8886784, but it doesn't work.

It's the same situation as you've explained: When I plug the USB flash drive into the port next to the front panel, "reading pendrive, wait" pops up and disappears. Nothing else happens, just the USB icon remains on the DDE display.

I tried differend flash drives, differend formatting (FAT32, FAT16, 2 GB) - no luck. You can save it as 8886784.zip, or unpacked as 8886784.jpu - it doesn't work either way.

Could you find a way to update your DDEs?

I could manage it ... it's very strange, why JBC can't provide a proper FW update guide!  |O

This procedure worked for me:

* The file 8886784.jpu must be saved in the root folder of a FAT32 formatted USB stick (flash drive).
* After connection with the station "Reading pendrive. Wait ..." pops up and disappears some seconds later.
* That's the secret: One has to press the i button on the front panel to get the question "do you want to update the firmware? [Y/N]"!
* [Y] will start the update and some time later a progress bar will indicate how much is done.
* At the end "Reading pendrive. Wait ..." comes up again; wait - after that the station can be switched OFF + the flash drive removed.
* From now on the splash screen must show the new FW version number.
If this won't work for you, try a differend FAT32 flash drive. Btw., in my case no USB cable was connected on the stations rear port.

This way you can check whether the station can read and write to the USB drive correctly:

Open the menu, go into Graphics -> View and select [Yes]. Enter a filename of your choice, followed by OK - then "Saving in USB memory" appears on screen. This could take some time; after that the screen shows a histogram and at the same time some data is written to the flash drive. Press OK on the front panel for stopping that and remove the flash drive. Connect it with your PC and you should find a root folder named GRAPHICS with your filename.csv.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod