Electronics > Manufacturing & Assembly

K1830 wont perform XY Initialize [SOLVED]


So i have a K1830. Only a few weeks old.

I did some test assembly runs, all turned out okay.
Sometimes the XY initialisation needed to be performed again, just went back to the manual test and executed the function, no problem.

Now currently i have a situation where it just wont do anything regarding xy initialize.
So my X and Y bed will not move. The button clickdown registers in the UI. It then freezes the ui, and after some time it unfreezes the UI. But it did not perform anything.

All the heads are in the correct place. I tried moving the head with the emergency stop on, tried all the positions -> no effect.
The break is working, the drives are working as well. If i lightly push the head in the X / Y direction, the pitch of the servo drive changes, so it's responding to the changed load.

So i'm quite stuck. It's sunday in belgium so no support ...

EDIT: Root cause was the laser line above the feeders. Be aware because no feedback in the UI about this.


So searching around i found this interesting repo.

I had wifi connected, and used and ips on my private network.
Maybe these collisions where to blame. I disabled the wifi and did a powercycle. No potato.

I have the following ips on the rpi on the K1830:

The X/Y motion part is, and arp is discovering it. That seems to be working as expected.
I guess it's in the Qt application that it won't send out the packets...
The initialize request is documented in the git repo, so will try to see if that UDP packet gets spit out..


Ok update:

It was the laser line that was causing an issue.
With some guidance i was able to disconnect them from the back and initialisation went through.
No warning in the UI tho, so be aware.


[0] Message Index

There was an error while thanking
Go to full version