Author Topic: pick and place machine  (Read 894 times)

0 Members and 1 Guest are viewing this topic.

Offline Munyua44

  • Contributor
  • !
  • Posts: 19
  • Country: ke
pick and place machine
« on: January 17, 2022, 11:03:25 am »
My pick and place machine has failed to work. it picks components but places them in the wrong position. How can this be solved?
 

Offline jmelson

  • Super Contributor
  • ***
  • Posts: 2410
  • Country: us
Re: pick and place machine
« Reply #1 on: January 17, 2022, 04:45:39 pm »
Try to understand which components are being placed where, and see if you can detect a pattern there.  Maybe you don't understand the coordinate system of the machine.  Does it use fiducials to adjust for where the board is placed?  Where is the "reference corner" of the board?  Is there a test mode where it shows you the offset computed by fiducial measurement?
Create a board placement file that only places one part on the board.  Get that to work, then try to get 2 parts to work.  Are you using placement data from the CAD package, or teaching the placement position?  Do you have solder paste on the board?  If not, the parts will bounce around.  For testing, put double-sticky tape on the board, and you can check accuracy by looking through the tape.
Sorry, a lot more questions than answers, but you didn't give us much info to go on.
Jon
 
The following users thanked this post: AmnevaR


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf