Author Topic: Unable To Calibrate 34465A 10VDC Range  (Read 3028 times)

0 Members and 1 Guest are viewing this topic.

Offline EE54Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: vn
Unable To Calibrate 34465A 10VDC Range
« on: December 25, 2023, 02:46:24 pm »
Hi everyone, I recently had a friend of my repair a broken 34465A that I bought. He manage to repair it but then it also had a problem where all DC ranges would drift over a few minutes. Problem was traced to a bad ADC buffer amp (OPA827). Now the unit will hold cal and not drift.
But another problem arise. For some reason, all DCV ranges will accept new values except for the 10 VDC range. Even when supplying 10 VDC and entering 10.000000VDC exactly, it will still show a 7mV error that just can not be calibrated away.
Could it be the 10VDC range has drift so much that it's outside the adjustable range? Could the new replacement buffer IC plays a role?
It also has a Cal count of 271, which seems like a lot.
 

Offline laichh

  • Contributor
  • Posts: 31
  • Country: my
Re: Unable To Calibrate 34465A 10VDC Range
« Reply #1 on: December 26, 2023, 03:52:25 am »
Hi EE54,

Did you perform [ADC and Zero Calibration] as mentioned in the Service Guide page 556 prior to the DC voltage gain calibration adjustment?
 

Offline EE54Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: vn
Re: Unable To Calibrate 34465A 10VDC Range
« Reply #2 on: December 26, 2023, 06:32:15 am »
My friend told me he performed all the calibration steps, tho I'm not sure if he used a proper shorting block or just use his 5700A to do the zero cal.
 

Online ITArchitect

  • Contributor
  • Posts: 12
  • Country: us
Re: Unable To Calibrate 34465A 10VDC Range
« Reply #3 on: March 11, 2024, 05:18:33 pm »
Has this issue been resolved?  After the zero cal, did you run the auto-cal to compensate for any temperature drift?  Curious on what was found or if it's still an issue.
 
The following users thanked this post: EE54

Offline EE54Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: vn
Re: Unable To Calibrate 34465A 10VDC Range
« Reply #4 on: March 21, 2024, 10:48:26 am »
Hi, this whole thing was put on hold for a bit as I am busy with other projects. I suspects that my friend diy calibration was not adequate, I doubt he used a proper 4-wire short for the zero cal.
I’m planning on having it sent to a local cal lab for a proper cal to see if the problem persists. I’ll update in 1-2 weeks.
 

Offline EE54Topic starter

  • Regular Contributor
  • *
  • Posts: 56
  • Country: vn
Re: Unable To Calibrate 34465A 10VDC Range
« Reply #5 on: July 10, 2024, 02:43:39 am »
Apologies for the extremely late response. I’ve been busy. :palm:
Finally got around to sending the unit to a proper cal lab.
Unit was off in the DCV,DCI, Ohm ranges.
After adjustments, the unit is reading DCV correctly again. No strange 7mV offset in the 10VDC range.
So it seems a in correct cal was responsible for the strange offset. :palm:
« Last Edit: July 10, 2024, 04:38:39 am by EE54 »
 
The following users thanked this post: Dr. Frank


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf