Electronics > Metrology

LM399 based 10 V reference

(1/231) > >>

fmaimon:
I'm designing a LM399 based 10V reference. It will be used with Richard's (amspire) general purpose power supply, probably the mk3 one.

Anyway, I want to make it with as high accuracy as I can, so I bought these resistors from ebay, in 75K, 32K and 3k11 values: http://www.ebay.com/itm/10-Vishay-TCC-S102C-S102K-Metal-Foil-0-01-Precision-Resistors-variety-value-/170926783729

They are supposedly used Vishay S102K metal foil resistors 0.01% 2 ppm/C. I've measured them with my Agilent 34410A and they are within specs on the resistance, but I didn't measure the tempco.

I also bought some LM399A from ebay and made this:


The PCB layout is this one



What do you think? As I don't have many LM399 and resistors (they are expensive!), I don't want to build one without some feedback.

free_electron:
throw away that op177... ad706 is the way to go.

much lower input noise.

ivan747:
You will need to pay attention to a lot of details in the power supply in order to achieve the kind of accuracy you will get out of this reference, if you get it right. High spec op-amps and remote sensing will be needed to remove offsets and line regulation over load, respectively. You will also have to take into account the switching noise (mk. 3 is designed to be used with a tracking pre-regulator). If you don't filter the output right, your accuracy and stability will be down into the noise.

Good luck, I'm looking forward to this project  :-+

codeboy2k:
Have you breadboarded this circuit?  It looks like a comparator.   How does it even start??

There is no clear starting current to get the zener into breakdown... perhaps the opamp starts hunting from rail to rail at the start and then it gets going? I am not sure. I don't like it this way, since you're not sure if it will start.

You picked an LM399, so you want stability, so let's give it some.  You should have a constant current source on that board to feed the zener some real, reliable current, about 1.5mA or so. The LM399 can (at its worst) change its output voltage about 2mV for every 1 mA change in input current.   The simplest constant current source is a constant voltage source and a resistor. So use your 15V regulated supply and a 5.6k resistor for about 1.45mA, and feed that into the top of the zener, it's not the best design, but it's ok.  I say it's not the best because the 15V can change, according to the LM317 specs.  i.e. it can change because of load, or temperature, or the 2 divider resistors that set the voltage can heat up and change, so your 15V changes too... When it changes, then your zener current will change (slightly), and the reference will change (slightly). How much it changes you will have to do the math :) If you are concerned about this, then the best love you can give your LM399 is to use another opamp to make a precision current source of 1.5mA and use that to feed the LM399. (there are many examples in almost every datasheet) 

Once you have a constant current, then you can take the reference voltage from the top of the zener and buffer it with a low offset, low drift opamp. You can also use this same opamp to gain up your reference to 10V here, if you wish to.

The LM399 is very stable, but not accurate, so you'll need some way to trim the voltage to your desired reference. That's why I suggested the opamp to buffer and gain it up and at the same time you can trim it to exactly 10V.

The suggestion Free Electron made to use a AD706 is perfect,  low offset, low drift, low bias, no chopper noise, and you get 2 in a single package, so one can be your current source :)  But to make a current source you'll need another shunt reference, it doesn't need to be the same spec as the main reference, because when it changes there's a much, much smaller effect on the main reference.


Rufus:

--- Quote from: codeboy2k on April 14, 2013, 10:50:29 pm ---You should have a constant current source on that board to feed the zener some real, reliable current,

--- End quote ---

His circuit provides a constant current source as stable as the reference.

I would be surprised if it doesn't start the OPA177 can't drive to ground. It probably sources some current while trying to, if not a bit of pull up on the op-amp output will fix that.

And yes if it is supposed to be a 10v reference it needs +/-5% of trim.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version