Electronics > Metrology

More Datron 4200 problems

(1/2) > >>

chilternview:
Well I thought the 4200 was working fine after the recent fixes described in another thread. Last night I calibrated it to my HP3458A, everything was working well.

Then this morning I powered it up and instead of the nicely calibrated settings, the output voltage was quite a bit higher than the set voltage. For example, on the 1V range, with output set to 1V, I read about 1.345v. On the same range with output set to 0.1v, it read about 0.523v, at 0.2v 0.616v, etc up in smaller increments. Similarly on the 10V range it read 13.63v at displayed 10V, at 1v on that range it read 5.289v etc. So a similar pattern for each range.

Running self test gave a FAIL2. Yet there was no fail on power up, nor was FAIL5 displayed at any point. According to the power on test details, a FAIL2 on self test is a sign of the overvoltage detector coming into effect when 75V or 125V is applied to the output.

Anyone seen anything like this?

chilternview:
Problem located... it was the +15v inguard supply to the reference divider board. This caused the offset seen, and also the FAIL2 on self test.

Replacing the 7815 regulator on the inguard power supply board did the trick, complete with the pre-existing kludge of the 3.3v zener in series with its input (I presume this was an afterthought to limit the 36v input to the regulator to less than its max of 35v). Why are Datrons so full of kludges like this?

alm:
Thanks for sharing the solution! I think in general it's better to stick with one thread per piece of equipment so the entire history is easily accessible, rather than having one thread per problem, which may or may not be unrelated. Or at least link to the original thread.

But I'm glad you posted how you solved it. That can be very helpful if you're experiencing a similar problem. What's especially frustrating is if someone posts "I fixed the problem" without saying how.

chilternview:
I take your point - I did wonder whether to just add it to the previous problems which were present, I believe, from before I acquired the 4200.

Anyhow, there is a new one: noise on the output. I have been trying to calbrate the 4200 using a 3458A (rather than a thermal trsnsfer standard). I have tried various interconnection schemes as outlined in the user manual - coax or twinax, guard / guard grounded / no guard etc. But whereas I can get reasonably stable readings on the 3458A for 1V and up ranges, there seems to be a lot of HF noise that makes readings jump about by tens or even hundreds on uV.

The HP3458A is set up as:
NDIG 8
NPLC 100
SETACV SYNC
RES .002
LFILTER ON

and the 4200 was setup at 1kHz with local sense (remote is not available for < 1V range). Using a scope I can see there is a lot of HF noise on the output which degrades the signal considerably at 10mV and more so at 1mV. Now from reading the theory of operation, it seems the millivolt output ranges are obtained by resistive dividers from the 1V range - so the noise must be picked up after this stage, it seems.

Is this level of noise to be expected - I guess a thermal transfer standard behaves like a low pass filter so is immune to HF noise? But the 3458A with its wideband AC amplifieris not?

alm:
I don't have a working AC board to test, but in general TVCs are pretty wide-band. The Fluke A55 series is specified from DC-50 MHz. So to me it sounds like a problem that the divided output is picking up noise.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks WYSIWYG Editor
Powered by SMFPacks Advanced Attachments Uploader Mod