Electronics > Metrology

Raspberry Pi for GPIB and data analysis: very easy and fully equipped

<< < (10/10)

krulls:
Hi e61_phil
Yes, the problem still exists as I haven't been able to get back to it. A load of things I hadn't planned on have been taking all my time, as you can see from the lateness of my reply. Any help for an old non-computer guy would be greatly appreciated. I thought I had someone locally who would take an SD card I was to provide and create a known good installation but that fell through.
Thanks to all who have helped!

e61_phil:

--- Quote from: krulls on February 23, 2022, 07:15:18 pm ---Hi e61_phil
Yes, the problem still exists as I haven't been able to get back to it. A load of things I hadn't planned on have been taking all my time, as you can see from the lateness of my reply. Any help for an old non-computer guy would be greatly appreciated. I thought I had someone locally who would take an SD card I was to provide and create a known good installation but that fell through.
Thanks to all who have helped!

--- End quote ---

I installed that recently on a raspberry pi 4 and it worked without issues. Maybe we can have a look together on your pi via a remote session

French_Nikolas:

I use a raspberry pi v2.1, with Raspberry Pi OS (Legacy) [Kernel version: 5.10, Debian version: 10 (buster)], and 4GB RAM.
I get an exception :


--- Quote ---Exception:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/base_command.py", line 143, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/_internal/commands/install.py", line 338, in run
    resolver.resolve(requirement_set)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 102, in resolve
    self._resolve_one(requirement_set, req)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 199, in _get_abstract_dist_for
    skip_reason = self._check_skip_installed(req)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 170, in _check_skip_installed
    self.finder.find_requirement(req_to_install, upgrade=True)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 572, in find_requirement
    all_candidates = self.find_all_candidates(req.name)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 534, in find_all_candidates
    self._package_versions(page.iter_links(), search)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 702, in _package_versions
    v = self._link_package_versions(link, search)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 777, in _link_package_versions
    support_this_python = check_requires_python(link.requires_python)
  File "/usr/lib/python3/dist-packages/pip/_internal/utils/packaging.py", line 33, in check_requires_python
    return python_version in requires_python_specifier
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/specifiers.py", line 676, in __contains__
    return self.contains(item)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/specifiers.py", line 681, in contains
    item = parse(item)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/version.py", line 28, in parse
    return Version(version)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/version.py", line 219, in __init__
    match = self._regex.search(version)
TypeError: expected string or bytes-like object

--- End quote ---

This exception occurs 4 times.

Is it normal ?

e61_phil:

--- Quote from: French_Nikolas on June 11, 2022, 09:50:55 pm ---
I use a raspberry pi v2.1, with Raspberry Pi OS (Legacy) [Kernel version: 5.10, Debian version: 10 (buster)], and 4GB RAM.
I get an exception :


--- Quote ---Exception:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/_internal/cli/base_command.py", line 143, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/_internal/commands/install.py", line 338, in run
    resolver.resolve(requirement_set)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 102, in resolve
    self._resolve_one(requirement_set, req)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 256, in _resolve_one
    abstract_dist = self._get_abstract_dist_for(req_to_install)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 199, in _get_abstract_dist_for
    skip_reason = self._check_skip_installed(req)
  File "/usr/lib/python3/dist-packages/pip/_internal/resolve.py", line 170, in _check_skip_installed
    self.finder.find_requirement(req_to_install, upgrade=True)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 572, in find_requirement
    all_candidates = self.find_all_candidates(req.name)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 534, in find_all_candidates
    self._package_versions(page.iter_links(), search)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 702, in _package_versions
    v = self._link_package_versions(link, search)
  File "/usr/lib/python3/dist-packages/pip/_internal/index.py", line 777, in _link_package_versions
    support_this_python = check_requires_python(link.requires_python)
  File "/usr/lib/python3/dist-packages/pip/_internal/utils/packaging.py", line 33, in check_requires_python
    return python_version in requires_python_specifier
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/specifiers.py", line 676, in __contains__
    return self.contains(item)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/specifiers.py", line 681, in contains
    item = parse(item)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/version.py", line 28, in parse
    return Version(version)
  File "/usr/share/python-wheels/packaging-19.0-py2.py3-none-any.whl/packaging/version.py", line 219, in __init__
    match = self._regex.search(version)
TypeError: expected string or bytes-like object

--- End quote ---

This exception occurs 4 times.

Is it normal ?

--- End quote ---

That is not normal. 5.10 should be fine.

Did you do a fresh install?

French_Nikolas:
Yes, it was a fresh install.

SD card 8Go,
Raspberry Pi OS (Legacy)
Kernel 5.10
Debian v10 (buster)
4GB RAM
nothing else.

installation done through ssh.

Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version