Electronics > Metrology

Shunt resistor issue

(1/8) > >>

LukaszRed:
Hello,
We have designed a shunt resistor using manganin and ETP copper. We have a task to get a shunt resistance 200uOhms but we are having a weird readings.
In reference to our spreadsheet for shunt resistance calculation (attached) we should get 200uOhms. We have few points of measurements, please find results of resistance check between point pairs below:
- 1-1 ~ 200uOhms
- 2-2 ~ 200uOhms
- 3-3 ~ 215uOhms
- 4-4 ~ 230uOhms
- 5-5 ~ 210uOhms

We checked it on CropicoD07 at 1A.
Nominal current for this component is 100A.
Is there any other reliable method of checking the shunt resistance without nominal current?

Or shall we measure it by checking voltage drop at nominal current between pins? Does anyone know how to measure shunt resistance properly and what are the factors affecting our readings (especially on top of the pins)?
Cheers,
Luk

TiN:
Well, if you inject test current at same point as you measure then your error comes from copper metal resistance.
What is the result if you have current injected at points 5-5 but reading taken at 4-4 and 1-1 ?

kfitch42:
I am a software guy so take what I say with a grain of salt, but my first impression is that when measuring from the "top of the pins" ( I assume you mean "3" and "4"), it has to go through more "squares". All of my knowledge on this topic comes from:

LukaszRed:

--- Quote from: TiN on July 11, 2016, 01:13:22 pm ---Well, if you inject test current at same point as you measure then your error comes from copper metal resistance.
What is the result if you have current injected at points 5-5 but reading taken at 4-4 and 1-1 ?

--- End quote ---

We measure only the voltage drop values in this test. Then converse the mV into mOhms and readings seem to be fine.

rob77:

--- Quote from: LukaszRed on July 11, 2016, 03:30:06 pm ---
--- Quote from: TiN on July 11, 2016, 01:13:22 pm ---Well, if you inject test current at same point as you measure then your error comes from copper metal resistance.
What is the result if you have current injected at points 5-5 but reading taken at 4-4 and 1-1 ?

--- End quote ---

We measure only the voltage drop values in this test. Then converse the mV into mOhms and readings seem to be fine.

--- End quote ---

but the question is where you inject the current.
you have to do a 4 wire measurement - use 2 wires to inject the current to points 5 - 5  and then use another 2 wires to measure the voltage drop across point 4-4 and 1-1.

EDIT:

forgot to mention.. 200mOhm for 100Amp nominal is way too much.... 0.2 Ohm @ 100Amp means 20V drop and therefore 2kW power dissipation...

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version