Author Topic: Teardown : Fluke 845A/AB/AR nullmeter/HZ voltmeter tweaks and mods (and repairs)  (Read 48137 times)

0 Members and 1 Guest are viewing this topic.

Offline MisterDiodes

  • Frequent Contributor
  • **
  • Posts: 454
  • Country: us
The circuit is really old style. The AC amp part is interesting to learn from. If available they could have used the µA741 for the DC amplification part (Q108-Q112).

The µA741 was not that good when it comes to noise leakage and similar. It was great because it was easy to use with internal compensation.

Noise wise the 741 is not that bad - 23 nV/Sqrt(Hz). The Fluke 845 should be somewhere at 100 nV/sqrt(Hz) - of this 70 nV/sqrt(Hz) are due to the resistors at the input alone.

This is getting way off-topic - but a 741 is not considered low noise at low freq. (< 10Hz) and yes it still is/was not that great compared to lots of techniques available then and now.  Especially when they first became more widely available in the early 70's.  Even today you can build a discrete amp or hybrid that outperforms a lot of single IC amps especially for low noise at low freq.  The recurring problem you run into with single die op-amp packages is it's always a tradeoff between input voltage noise or low input current noise - and a null meter sort of wants both, even at the DC gain stage.

Real world measurement - and you'll see that even a bit more modern single 741 would generate a fair amount of noise compared to what you can do (and what is done in these meters) with discretes (This lab report done in 2005 and could be done with better amps today):

http://www.cs.ru.ac.za/research/g02c0108/files/noisehandin.pdf

The '845 / '155 / 419a will generally have less noise than the more simple and "trivial" op-amp attempts, but a modern high performance hybrid (discrete + IC) solution can probably work very well.  Part of the real magic occurs in the stable voltage zero and current offset systems built into these meters.

All of this is hard to do at 3uV ~ 1uV and lower ranges.  That's noisy territory.

It should also be noted that a lot of times with voltage bridge  measures (KVD + 732 for instance) you're maybe not working a lot at those very lower ranges - probably 10uV or 3Uv is a good range to be on if you're playing with LTZ's (10uV is 1ppm in the 10V world).  Resistance bridge null meter settings will depend on what you're after, and those lower ranges can help.

« Last Edit: September 05, 2017, 09:32:35 pm by MisterDiodes »
 

Offline Vtile

  • Frequent Contributor
  • **
  • Posts: 993
  • Country: fi
  • Ingineer
I need to clarify my uA741 note. It were mostly meant to be kind of a historic sidenote, of the IC technology state back in the era when 845 did come out on the market. So please lets not took it too far away offtopic. This nullmeter discussion is most interesting as most of the discussions in here at metrology section.

As a technical side note (OT again since I do not have "big boys" instruments) I tested the bias current of my Meratronic/Marconi Meratester (Poland, 1970s IIRC) in 1.5mVdc range and did end up result of ~700fA over 10 meg resistor (60uV over 97 MOhms), the device have a null / center zeroed mode for bridge use. It does use HLY7006 hybrid amp. Keithley 197A did show wild readings as high as 1.5mV over 10 meg resistor.  :-\
« Last Edit: September 07, 2017, 09:27:15 am by Vtile »
 

Offline classicTEK

  • Contributor
  • Posts: 44
Hello All,

I figured this would be the place to keep the cumulative knowledge base for these tools, so the thread lives and breaths.

Mine is an early 80's vintage AR and will not fall into spec for Noise when ZERO'ing or "SHORTED" for operating stability. It drifts around null about 1uV back and forth and occasionally jumps more in the 1uV setting.  Setting ZERO is like a cat chasing its tail.

As I am reading the manual it EXPLICITLY says "Do NOT attempt to clean switches."

This is all well and good for all of the obvious reasons; however with an instrument as old as the 845 and an unknown history it worries me a bit. 

How have others made certain it is not dirty switches causing any unstable readings when ZERO'ing and operating the unit?  Did you throw caution to the wind and use any certain method to clean the switches with success or did you simply follow the manual to a tee and search elsewhere for the problem as is stipulated in the TS procedures?

I just don't want to jump to component level TS before doing the most common of problem solvers with old gear.........cleaning DIRTY SWITCHES.

Thoughts?

Cheers,

David
 

Offline ManateeMafia

  • Frequent Contributor
  • **
  • Posts: 719
  • Country: us
The safe bet would be they are referring to chemicals that can destroy the materials in the switch and/or reduce the isolation from the front panel to the guarded section. Contact cleaner would definitely not be recommended but IPA may also be bad. You can examine the switches with a magnifying glass on the lowest ranges. Caig DeoxIT would be my first choice in such a situation where alcohol might cause the plastic parts to break. Assume they are already brittle with age.

I would guess any powered device would need the power supply checked first. If the 845AR is using the optical chopper amp, then the neon bulbs would also be suspect.

Clean your binding posts. I find a lot of the older gear has hidden corrosion inside and could use a good cleaning.

Good luck.
 

Offline classicTEK

  • Contributor
  • Posts: 44
GREAT!!!!!  That was my initial plan:

Clean all switches, binding posts, and grounding straps with a very deft hand, q-tips, moistened w/de-oxit.

Excersice the legs of all socketed transistors in place.

I will try this first and see if it helps.  If not, it is off to the races following the TS procedures in the manual.

Mine does have the chopper circuit, but my neons seem bright and strong.  HOPEFULLY!!!

Thank you and I will report back with my results to hopefully help others.

Cheers,

David
 

Offline wn1fju

  • Regular Contributor
  • *
  • Posts: 244
  • Country: us
For what it's worth, the drift on my 845AR improved substantially after I scrubbed the range resistors with alcohol (and let them dry
thoroughly).
 
The following users thanked this post: Squantor

Offline classicTEK

  • Contributor
  • Posts: 44
I have searched all over for a video of a fully functional and calibrated 845xx nulling on short or zeroing.

Could someone be so kind as to make a quick video and post it so those of us whom have never owned or used one can see the proper operation? Or more importantly the behavior of one that is functioning correctly.

I for one would truly appreciate that.  Especially for inspiration!!!

There zero videos of the 845 in action.

Cheers,

David
 

Offline Conrad Hoffman

  • Super Contributor
  • ***
  • Posts: 1221
  • Country: us
    • The Messy Basement
Sounds like watching grass grow. The needle just slowly drifts to where it's going, maybe wanders a bit and stops. At the most sensitive settings it will wander continuously due to noise. Alas, no way to make a video here- not a cell user!
 

Offline classicTEK

  • Contributor
  • Posts: 44
Conrad,

Thank you for that !!!!

I must admit publicly that I should not have been working and posting last night.  I have found myself in the awkward position of discovering my tired mind an eyes were simply not connecting in the wee hours of the night.

I was actually on the 1uV scale and was reading it as if it were on the 10uV scale!!!   :-[

Now that I am well rested and have LOOKED at my scales  and meter......I am experiencing about .1uV of noise when shorted on the 1uV scale. |O

I still think I am going to change out CR207 to see if that helps with what I "think" is a bit of a stability issue to get this dialed in if possible.
 

Offline FTM777

  • Newbie
  • Posts: 4
Builder
Would love some more information on your conversion please.
Nick
 

Offline SeanB

  • Super Contributor
  • ***
  • Posts: 15318
  • Country: za
Just remember there are different grades of 741 ( or at least there used to be), and you could get somewhat more expensive ones that were selected for lower noise, and very low 1/f noise, though those typically were part of the military spec versions. You could get them as practically noise free for popcorn noise over the full military range, and they were at least good enough for 14 bit converters. Generally they were the TO100 cased versions, as those have a lot lower stress on the die, and the performance was quite good.
 

Offline velik_kazakov

  • Regular Contributor
  • *
  • Posts: 51
  • Country: bg
Hi,
last night I start to restore the second one Fluke 845AR. I score it from ebay and receive it in last week.
I find some bad caps and desoldered resistor on it. Someone is repaired the null detector in the past.
It start to work now, but still have some probelms. I find that the neon bulbs not fire every periond. Something else, when I turn off the light over the instrument, the neons stop to fire. When I turn on the light . they start to fire. I check all around it and all is OK ( I think). The miltivibrator wirk fine and stable. Have a HV on the pin 9 of the traf that drive neons. Other voltages (+15 and -15) from the same traf is OK. Maybe the neons need to be exchanged. Want to ask, am I right or need to check to find something else. Do you have the same problem with neons.
Here I post a video with the nepns. https://youtu.be/FcnWiiL_dJA
Sorry for my bad English!
 

Offline doktor pyta

  • Frequent Contributor
  • **
  • Posts: 286
  • Country: pl
    • RF Scientific
Yes, neons need to be exchanged.

Offline velik_kazakov

  • Regular Contributor
  • *
  • Posts: 51
  • Country: bg
Thanks! Will look to order some neons or will do a leds mod to this one Null Detector. My other one 845 work well for now with original neons and I maybe will try led mod.

Edit:
Find some time now to do all. Make the mod with the leds from Epson inkjet priner. It is the same in R285, P50, L800, 1500,,, all use the same leds and I have lots of it. I look that the emitted light is very simmilar to the neon light. Do some mods and instal 2 diodes with 3,2 kohm resitor in series. Exchange the places of both to keep the oem diodes as before. Finaly all work well for me. I record the internal noice for some time and it looks good. Thank you again!
« Last Edit: April 15, 2019, 04:00:16 am by velik_kazakov »
Sorry for my bad English!
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
I bought a Fluke 845AR a few days ago, but I'm not very happy with it's performance. The needle is anything but stable and noise is in the order of 500nVpp in 3µV range.

First I adjusted full-scall deflection in the 10V range using one of my LTZ references. Next I adjusted the pot for the 84Hz (12ms) chopper frequency. I then used my reference to adjust for 1V output voltage and recorded the output voltage overnight using my R6581 (1V range and 10NPLC) in the 3µ range and with the input shorted. Within the first about two hours I readjusted the zero pot. As you can see the noise reading is rather high. I measured a few test points given in the manual and so far everything looks quite okay.
Will measure the capacitors next week, once I have the ESR meter at hand to see in which condition the electrolytic caps are. Any additional hint what to look for?

-branadic-
Metrology Meeting 2020 on 06.06.2020
 

Online Kleinstein

  • Super Contributor
  • ***
  • Posts: 6818
  • Country: de
The 845 is not a very low noise meter. It is more like very low bias. At the input there are some 300 K of series resistance and this alone gives quite some noise (some 70 nV/sqrt(hz)). The amplifier itself may also add noise. This could well possibly in the same range - otherwise they may have chosen smaller resistors.

For very low voltages it may need some additional averaging, e.g. in the digital domain. Digital filtering can by FIR type and thus need less settling time.
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
Can't agree on that, the manual says it should be 250nVpp in the 3µV range, 200nVpp in the 1µV range as maximum noise with input shorted.

-branadic-
Metrology Meeting 2020 on 06.06.2020
 

Offline Dr. Frank

  • Super Contributor
  • ***
  • Posts: 1776
  • Country: de
Have a look at the neon drive waveforms.
Noise that high might indicate bad neons.
Noise is too high..
Frank
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
Thanks Frank, will look at that. Had already ordered a pack of 10 new neons, that will arrive soon. I know that there is this LED mod, but I want to keep the unit as original as possible.

-branadic-
Metrology Meeting 2020 on 06.06.2020
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
Frank, seems you are absolutely right on the neons. While I can measure about 105V across one of them the other one is only half in amplitude. So need to wait for the neons to arrive and replace both of them.

-branadic-
« Last Edit: August 03, 2019, 09:00:39 pm by branadic »
Metrology Meeting 2020 on 06.06.2020
 

Offline Conrad Hoffman

  • Super Contributor
  • ***
  • Posts: 1221
  • Country: us
    • The Messy Basement
Note that the trigger voltage of neons is light sensitive. That's normal. Long ago I worked on Ilex electronic shutters. We had a neon in the box that stayed on full time to illuminate the neon used for timing, to stabilize it.
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
I went through the dumpster of my colleague today and found a few neon bulbs. Unfortunately they turned out to be to long, though working. By accident I searched on the web if Conrad Electronics, we have a store here in town, has some neon bulbs and it turned out they have and they have them in stock in their store.

By the way: most of the time the stuff you need is available online only and can be ordered, which takes a few days.

So I went to the store and bought two packages, each containing 5 bulbs, 1.99€ each package. The neons are now installed and everything is adjusted. Indeed one of the original neons were already black on one side. Maybe I could have simply turned it around and use the clean side of it, but hey we have new ones :)
The needle is now stable down to the 1µV range, so we can call that a repair. Excellent :)
So if you need neon bulbs and need them fast, look for this one: Barthelme 00082305 Glimmlampe 115 V, 230 V 0.25 W T1 3/4 MG Transparent

-branadic-

EDIT: Picture of a measurement in the 3µV range before and after bulb replacement for comparison. Vertical scale is identical.
« Last Edit: August 06, 2019, 04:14:53 pm by branadic »
Metrology Meeting 2020 on 06.06.2020
 
The following users thanked this post: doktor pyta, 2N3055, maginnovision, syau

Offline guenthert

  • Frequent Contributor
  • **
  • Posts: 334
  • Country: us
  As far as I understand, there are different kind of Neon bulbs:  those meant for indication/illumination, which are still readily and cheaply available (but very limited on/off cycles) and those used for switching purposes in the sixties, which seem to be unobtainium today.  I got a HP419A with failing Neons and would love to be proven wrong.
« Last Edit: August 07, 2019, 04:30:35 am by guenthert »
 

Offline branadic

  • Super Contributor
  • ***
  • Posts: 1523
  • Country: de
The only difference I see is the distance and the length of the rods.
Anyway, I have ordered some bulbs that are sold as NEW Box of 10 Neon Bulb NE2U A3C Indicator 105 to 125 Volts AC/DC FREE RESISTORS. I will see how they differ from the original ones I desoldered once they arrive. But I couldn't wait any longer to see, if there is something else broken on my unit. If my current replacements fail early I'll let you know.
And I will change and measure behavior of the ebay items once they arrive, so we can see if there is a noticable difference. But I wouldn't expect any.

-branadic-

Edit: Can't see a real difference in the datasheets except that small difference in current and maximum breakdown voltage, which seems negligible:
1.9mA and 95Vac for AC3/NE2U
1.7mA and <=90Vac for the Barthelme 82305
« Last Edit: August 06, 2019, 06:05:45 pm by branadic »
Metrology Meeting 2020 on 06.06.2020
 

Offline Dr. Frank

  • Super Contributor
  • ***
  • Posts: 1776
  • Country: de
If you really have found such a simple solution, I'll call you a genius.

I remember many discussions on volt-nuts / time-nuts, which neon replacement to use, as the ignition voltage and pairing was crucial, I think, something like 90V, or so..
The specialty was, as Conrad indicated, that these Neons probably had some radioactive substances inside, to lower this ignition voltage.
But anyhow, if it works flawlessly, then maybe I will repeat your stability tests and maybe replace my Neons also..

I've got an 845AR from late Singer Pharmacy, for a reasonable price (was the sell-out, maybe), and it's working quite ok for my purpose, i.e. autocal of my Hammon 100:1 / 10:1 divider.
Not the least quiet nullmeter, but with a bit of patience :popcorn: it works very well. Especially the extremely low bias gives good results.

Frank
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf