Author Topic: after a few seconds stm32 running suddenly freezes  (Read 163 times)

0 Members and 1 Guest are viewing this topic.

Offline tariq

  • Contributor
  • Posts: 16
  • Country: ir
after a few seconds stm32 running suddenly freezes
« on: April 20, 2021, 03:31:12 pm »
I'm using stm32f101vbt6 by keil debugger after my program running for a few seconds micro freezes and main program stops so main clock stops .i increased min heap size and stack size but that doesn't helped me. in keil my program size is this:

Program Size: Code=105880 RO-data=1156 RW-data=2500 ZI-data=10372

in my codes I'm using RTC global interrupts , EXTI interrupts , TIM interrupts ,USART interrupts Is it because of interrupts?do i should do some thing about them that i don't know? or some thing else?

i can't use IWDG because I'm using stop mode and i cant disable IWDG in stop mode.but even if i not using it that freeze should not be happen after 10 seconds my microcontroller starts.

appreciate your help.
 

Offline georges80

  • Frequent Contributor
  • **
  • Posts: 854
  • Country: us
Re: after a few seconds stm32 running suddenly freezes
« Reply #1 on: April 20, 2021, 03:38:39 pm »
Given your detailed explanation of what is happening and your hardware/software design, I'd say you either have a problem in the hardware or in the software, or both. That should narrow it down nicely for you.

Seriously, do you imagine we have some kind of crystal ball here?

cheers,
george.
 
The following users thanked this post: Evan.Cornell, nuclearcat


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf