Author Topic: Anyone used Lattice ICE40 FPGAs ?  (Read 30088 times)

0 Members and 1 Guest are viewing this topic.

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #25 on: October 25, 2013, 11:23:48 am »
They have a new low cost evaluation kit out BTW.

http://latticesemi.com/Home/Products/DevelopmentBoardsAndKits/iCEstick.aspx

Yup, mine just arrived this morning. Thought I'd give it a spin, but no luck getting a license today it would seem.

http://www.latticesemi.com/Support/Licensing/DiamondAndiCEcube2SoftwareLicensing/iceCube2.aspx
http://www.latticesemi.com/Support/Licensing/DiamondAndiCEcube2SoftwareLicensing/DiamondFree.aspx
http://www.latticesemi.com/Support/Licensing/DiamondAndiCEcube2SoftwareLicensing/Versa.aspx
http://www.latticesemi.com/Support/Licensing/DiamondAndiCEcube2SoftwareLicensing/DiamondSubscription.aspx

All say three-o-two FU!  >:(

On a hunch I just tried same as above on https, but no dice either. Tried on several browsers. Not that it would matter with a 302, but what the hell. Wayback machine doesn't point to any recent booboo's either (same urls in august 2013), so I don't get it. Basically it just looks like someone forgot to deploy a few files. :P Or rights on folder, since this looks like windows monkeys. I would bet $10 on incorrect rights on the DiamondAndiCEcube2SoftwareLicensing folder. Anyone got an internal phone number of whoever does lattice's website?  ;D Wait, make that a $25 bet. That would cover for the icestick.

Other than that, has anyone recently obtained a license from Lattice?

I wonder what is faster, mailing them to fix it so I can get a legit license, or google translating a few chinese sites for a "fix". :P
 

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #26 on: October 25, 2013, 11:37:03 am »
Well, it's not that folder either.  :-//

*hands over $25 to other self*
 

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #27 on: October 25, 2013, 12:31:25 pm »
loooool. Okay, so license request page doesn't work. Best tell their support team about it then!

Online Technical Support: Click here to create and submit your technical support case

http://www.latticesemi.com/ocm

*urgle!*

classic.  :-DD

Oh well, I'll give it another go after the weekend. :P
 

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #28 on: October 30, 2013, 08:32:31 am »
So what is the verdict now? I found this thread because I was researching the HK4K 144pin, probably for the same reasons as you guys, I want a small scale FPGA which can haz PLL and fast clock delay line  taps.

Well, for this price level the clocking resources are pretty good. I mean, it's got a PLL. Nuf said. :P Things like FF toggle rate are a bit low (256 MHz max), but VCO frequency is quite decent (533 MHz max). And quite interestingly they have local clock inversion, which I've not seen before on this type of el cheapo fpga. So on the models with 2 PLL's you could generate 4 staggered clocks (0,90,180,270 degrees) at say 500 MHz which is quite nifty. Then with some clock enables you'd clock the FFs at 250 Mhz.

Oh and they have 150 ps step size for the delay adjust. Not super, but again ... for this price level that's damn nice.

As for tools, I just spent some time playing around with it. After I told the licence dude/dudette my favorite color and underwear preferences they favored me with a license.

Short version:
Tools are a bit of a mixed bag, but overall definitely positive. Pending any suckage level updates where applicable.

Long version:
The icecube2 gui definitely feels a little klunky. Earlier on Mike described it as "a bunch of random tools held together with sticky tape", but he was being generous. They probably started out with the intention of using sticky tape, only to find out they were all out of tape. So they used hot glue for some parts, but then the glue gun went *ffzzzt* and they had to tack the rest together with silly putty and hope for the best. The internal editor ... has no syntax highlighting. Seriously?

The workflow is not super, but not as bad as was mentioned earlier. For the icestick board I could just download the kit design files and use the project files. Press the magic BUILD EVERYTHING & STUFF button and off we go. Runs everything, including generating the .bin file. The floorplanner is rather limited. It's just about enough to inspect for correct placement but that's about it. No tcl scripting to quickly select your fav resources + do some highlighting. You can drag & drop to fuck up your placement constraints, but not sure yet if I like it. :P

The BIG WIN for me is that it does support SystemVerilog for synthesis. Yay! Of course the silly putty gui doesn't support it. That would just be too easy. But they do use synplify pro as backend, and you can also run the gui. You can even run the gui at the same time and do a batch run, something that's not always possible with some of the free licenses. So basically the mission is to use icecube to cobble together a project and then get into synplify pro as quickly as possible. At least there you have a decent environment (oh look, syntax highlighting ;) ). And as said, the free license comes with sysv support.

Integration between synplify & icecube is what you would expect for silly putty. Should you reeeeaaaally like the icecube gui, you can also enable SystemVerilog for that flow. You'll have to manually edit the project file to change the verilog mode from v2001 to sysv. But basically you'll want to do everything in synplify except for floorplanning. Well, and the pll wizard generator thingy.

And of course simulation just has to be total shit. :P They use Aldec, which means windows only. No biggie, but it would have been nice if they used modelsim. But oh well, can't complain for a free license. Besides, it looks like modelsim is also possible, but I still have to do the simulation library dance...

Anyways, icestick (ICE40HX1K, aka TQFP144 package with 1 PLL) ... only $25 at digikey/mouser. You know you want to!
 

Offline Stonent

  • Super Contributor
  • ***
  • Posts: 3824
  • Country: us
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #29 on: October 30, 2013, 08:57:47 am »
Anyways, icestick (ICE40HX1K, aka TQFP144 package with 1 PLL) ... only $25 at digikey/mouser. You know you want to!

I know I want to! That's the problem! I always want to!

I can thow it on the stack of $25 eval kits I already have that have never been used except being powered up one time.
MSP430 Chronos Watch
Stellaris Launchpad
Tiva C Launchpad (later to find out it was a Stellaris basically)
C2000 Launchpad

Other:
Atmel Samples
Noritake VFD Sample
MSP430 Launchpad (I have used this a few times)

On the way now:
A couple of ATMega48v QFPs

On the way soon:
$20-$25 worth of passives, transistors, op-amps, logic chips from Tayda

Current:
Actually see if my Velleman PIC Programmer that I built works
Final wiring of my Geiger Counter and BNC Installation
Build an XR2206 function generator circuit on protoboard


HOLY CRAP I had no idea how much many hobby projects I had!
« Last Edit: October 30, 2013, 09:00:42 am by Stonent »
The larger the government, the smaller the citizen.
 

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #30 on: October 30, 2013, 01:04:19 pm »
I can thow it on the stack of $25 eval kits I already have that have never been used except being powered up one time.

I'm sure you're not the only one who has more fun projects than time. ;)

Quote
On the way soon:
$20-$25 worth of passives, transistors, op-amps, logic chips from Tayda

I only recently found out about Tayda, and their interesting pricing. Doh! Did you notice any particularly interesting tidbits while shopping?
 

Offline Stonent

  • Super Contributor
  • ***
  • Posts: 3824
  • Country: us
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #31 on: October 30, 2013, 07:05:29 pm »
I can thow it on the stack of $25 eval kits I already have that have never been used except being powered up one time.

I'm sure you're not the only one who has more fun projects than time. ;)

Quote
On the way soon:
$20-$25 worth of passives, transistors, op-amps, logic chips from Tayda

I only recently found out about Tayda, and their interesting pricing. Doh! Did you notice any particularly interesting tidbits while shopping?

They are apparently quite popular with DIY guitar effects pedal enthusiasts. While doing research on Tayda I found numerous guitar related sites referring people to them. That explains why they have all those foot sized cast aluminum enclosures and knobs that are replicas of ones made by Marshall and other guitar related companies. They also have many more foot activated switches than you would think a site would normally have.

I'm beginning to think that my local electronics store uses Tayda as a supplier because they seem to have the same knobs, trimmer pots, and more interesting things that seem too much a coincidence.  Tayda sells ST branded 2N3055 transistors for $0.99 and they sell the same ones for $1.49. In fact there seems to be pretty much a 50 cent price differential on nearly every part that they seem to have in common.

Tayda is also the first site that I've seen that lets you buy items less than 1 cent each in quantities of 1.

They don't have a really good supply of microcontrollers and no programmable logic devices. Their logic chips seem to cover the most popular items.

No plastic project boxes though, I really would like some of those.  I've been looking for project boxes but don't want to spend 5 to 7 dollars on an enclosure for an adjustable 555 timer circuit that cost me $1 to make.

15% Discount Coupon Code : 888444
Valid till 2 November 2013 ( 6pm New York time )
The larger the government, the smaller the citizen.
 

Offline mrflibble

  • Super Contributor
  • ***
  • Posts: 1947
  • Country: nl
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #32 on: October 31, 2013, 06:06:28 am »
They are apparently quite popular with DIY guitar effects pedal enthusiasts. While doing research on Tayda I found numerous guitar related sites referring people to them. That explains why they have all those foot sized cast aluminum enclosures and knobs that are replicas of ones made by Marshall and other guitar related companies. They also have many more foot activated switches than you would think a site would normally have.

Yeah, I noticed that as well while googling. Apparently stomp boxes are a popular thing.

Quote
I'm beginning to think that my local electronics store uses Tayda as a supplier because they seem to have the same knobs, trimmer pots, and more interesting things that seem too much a coincidence.  Tayda sells ST branded 2N3055 transistors for $0.99 and they sell the same ones for $1.49. In fact there seems to be pretty much a 50 cent price differential on nearly every part that they seem to have in common.

Heh, I had something similar while buying knobs on ebay. I just knew those ebay stores were going to be a proxy for some cheaper place. But I couldn't find it so screw it, I will pay a little stupidity tax. At least that way I'll have some rotary encoders with colored knobs, and can get on with the project. And of course a few days after that ebay order I find out about Tayda. :P Typical.

The aluminum enclosures actually look pretty interesting. Maybe not for a $1 project, but a $5 box for a $20 - $50 in parts + pcb project looks quite doable. Well, more than $5 after shipping, but still nice.

Quote
Tayda is also the first site that I've seen that lets you buy items less than 1 cent each in quantities of 1.

Yup. And mosfet pricing looked interesting as well. Too bad they don't have any smd caps in the 1uF - 10 uF range, because I could use some.

Quote
15% Discount Coupon Code : 888444
Valid till 2 November 2013 ( 6pm New York time )

Thanks!  :)

And to keep it a bit ON topic as well: I've been playing some more with that icestick + toolchain, and I definitely like it. The icecube software itself is a bit silly, but if you supplement it with synplify then it's quite nice. For example, icecube doesn't even have an RTL view after synthesis. :P But luckily you can do that in synplify.

The pin constraints editor is not exactly great, but once you know it's "features" it's quite usable. What is rather stupid is that you first have to do a synth run before you can assign a pin location. Yeah, as if I don't know where this signal is going right at the moment I am adding it to the top level module. But oh well.
 

Offline denizcan

  • Regular Contributor
  • *
  • Posts: 59
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #33 on: November 07, 2013, 11:52:09 pm »
Talking about BGA and cheapness. The following is 1 in stock:

http://www.digikey.com/product-search/en?pv1291=757&FV=fff40027%2Cfff80166&k=xilinx&mnonly=0&newproducts=0&ColumnSort=0&page=1&stock=1&quantity=0&ptm=0&fid=0&pageSize=25

Anyone want the final one? :) I'll track it's stock level. And I am really interested to see the project in which this chip is used.. :)
 

Offline jipihorn

  • Contributor
  • Posts: 18
  • Country: fr
    • jipihorn blog
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #34 on: December 20, 2014, 04:41:19 pm »
Hello,

I dig up this one, because I got one of these iCE40-HX8K boards and I wonder if anybody could, at last, program them.

The Diamond programmer does not recognize the USB port, although it is listed in the device manager (I use Windows 8.1). It's a FDTI chip and it is recognized as a COM port. But, after hours and hours of research, I couldn't use this board.

I always have the same message :

ERROR - Failed to Open FTDI USB port. Make sure to select the right cable type.

And, curiously, it detects two "cables" or "FTDI USB Host chips" whatever that means - I only have one usb cable connected. In any case, none of them works. It's beyond understanding, nothing make sense. I have the impression to have some 80's bag of stuff without any coherence.

The software development platform is a pure mess. They ask to install iCECube, Diamond without saying exactly which one is used for. All I can find is that Diamond is used only for programming (using the standalone programmer) and ICECube is the actual development tool. What a mess.

Only one sample code (a blinking led) without any documentation. Bus, as I couldn't even program something, it's pretty useless.

It'a a pity, I was searching for a small FPGA solution (with tqfp package)  and it's absolutely useless.

Jerome.
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #35 on: December 26, 2014, 09:06:52 am »
This was pretty much my experience a few weeks ago. I thought I'd try out an ICE40 and a MACHXO2 eval board.

Firstly they use two different, but similar looking, IDEs/toolchains for some weird reason.

Obtaining a license file seemed obvious, but wasn't, I read the docs which said I needed to send an email to request one, how quaint. A couple of days later I had a reply with a URL to do it through a web page.

I had to keep swapping license files around to switch betwen the two IDEs. i am sure you can avoid that if you invest time in hacking a combined license file or something, but it's just another reason to lose interest.

The documentation only seems to be aimed at getting you to a very limited point, but no more.

But the key point as you say appears to be that you can't actually program the device.

At the point where it seemed I was going to have shell out $150 for a programmer I lost interest.

Is the Diamond programmer the only way of programming these device, or can I use one of the half dozen or so JTAG devices I have accumulated?
 

Offline mikeselectricstuff

  • Super Contributor
  • ***
  • Posts: 12037
  • Country: gb
    • Mike's Electric Stuff
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #36 on: December 26, 2014, 09:28:14 am »
This was pretty much my experience a few weeks ago. I thought I'd try out an ICE40 and a MACHXO2 eval board.

Firstly they use two different, but similar looking, IDEs/toolchains for some weird reason.

Obtaining a license file seemed obvious, but wasn't, I read the docs which said I needed to send an email to request one, how quaint. A couple of days later I had a reply with a URL to do it through a web page.

I had to keep swapping license files around to switch betwen the two IDEs. i am sure you can avoid that if you invest time in hacking a combined license file or something, but it's just another reason to lose interest.

The documentation only seems to be aimed at getting you to a very limited point, but no more.

But the key point as you say appears to be that you can't actually program the device.

At the point where it seemed I was going to have shell out $150 for a programmer I lost interest.

Is the Diamond programmer the only way of programming these device, or can I use one of the half dozen or so JTAG devices I have accumulated?
Can't comment on the ICE40 stuff but Diamond license generation is automatic - web request, emailed to you immediately.
The whole ICE40 was bought from SiliconBlue, hence the seperate devtools.
 
Youtube channel:Taking wierd stuff apart. Very apart.
Mike's Electric Stuff: High voltage, vintage electronics etc.
Day Job: Mostly LEDs
 

Offline jipihorn

  • Contributor
  • Posts: 18
  • Country: fr
    • jipihorn blog
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #37 on: December 26, 2014, 02:35:29 pm »
This was pretty much my experience a few weeks ago. I thought I'd try out an ICE40 and a MACHXO2 eval board.

Firstly they use two different, but similar looking, IDEs/toolchains for some weird reason.

Obtaining a license file seemed obvious, but wasn't, I read the docs which said I needed to send an email to request one, how quaint. A couple of days later I had a reply with a URL to do it through a web page.

I had to keep swapping license files around to switch betwen the two IDEs. i am sure you can avoid that if you invest time in hacking a combined license file or something, but it's just another reason to lose interest.

The documentation only seems to be aimed at getting you to a very limited point, but no more.

But the key point as you say appears to be that you can't actually program the device.

At the point where it seemed I was going to have shell out $150 for a programmer I lost interest.

Is the Diamond programmer the only way of programming these device, or can I use one of the half dozen or so JTAG devices I have accumulated?

Hello,

Getting licenses was the one of the few task that went well.
As far I could tell, it is the way to program these. The iCE40 chips are listed into the available devices with all sorts I2s flash memories (the kit uses a Micron one). This seems to be adequate for the job, but only if a connexion could be done.

The only thing I could do was to open a ticket at Lattice. The back and forth mailing has only begun ("have you to tried to turn it off and on again ?"), but at least I could get an answer quickly from Lattice, even for a cheap kit. Perhaps I was unlucky to get a PCB with a fault.
But I don't even understand the usb logic and this "double cable" stuff.

Jerome

 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #38 on: December 27, 2014, 06:05:16 pm »
Ok, many thanks for the responses. I hadn't realised that ICE40 was a buy out.

The boards I have are:

XO2-7000HE breakout board
LCMXO2-1200ZE-P1-EVN LCD I2C Pico board
ICE40HX1K-BLINK-EVN

Before I try again, do I need a separate programmer for these to be able to save my own stuff (non volatile) on them, and if so does it have to be the Lattice unit? I could get the demos to run but that was where it seemed to end.

Many thanks.
 

Offline mikeselectricstuff

  • Super Contributor
  • ***
  • Posts: 12037
  • Country: gb
    • Mike's Electric Stuff
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #39 on: December 27, 2014, 06:11:55 pm »
Ok, many thanks for the responses. I hadn't realised that ICE40 was a buy out.

The boards I have are:

XO2-7000HE breakout board
LCMXO2-1200ZE-P1-EVN LCD I2C Pico board
ICE40HX1K-BLINK-EVN

Before I try again, do I need a separate programmer for these to be able to save my own stuff (non volatile) on them, and if so does it have to be the Lattice unit? I could get the demos to run but that was where it seemed to end.

Many thanks.
They all have onboard programmers
Youtube channel:Taking wierd stuff apart. Very apart.
Mike's Electric Stuff: High voltage, vintage electronics etc.
Day Job: Mostly LEDs
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #40 on: December 28, 2014, 07:58:12 am »
Thanks for confirming Mike, I guess I'll have another shot.

Howard
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #41 on: December 28, 2014, 01:04:53 pm »
I've spent all morning on this now, with about an hour fruitlessly battling with the FTDI driver which was probably a waste of time now as I don't think that's the problem.

I've now tried the Lattice Diamond IDE on three different physical machines, all Windows 8.1, two x64 and one x86.

The version of the IDE is 3.3.0.109, with the x64 and x86 machines installed with the respective versions (x64/x86) of Lattice Diamond.

Neither of the x64 machines work: the programmer is not properly recognised. The error is the same on both x64 machines, in that the FTDI programmer is detected but the JTAG communication fails. The x86 install however does work.

On all three machines, the programmer is enumerated and installed in Device Manager as the following:

- USB Serial Port (COMx)
- USB Composite Device
- USB Serial Converter A
- USB Serial Converter B

This is the Output pane in the Lattice Diamond IDE on the failing x64 boxes:

Code: [Select]

Lattice VM Drivers detected (HW-DLN-3C (Parallel), HW-USBN-2B (FTDI))
Starting: "prj_src add -exclude "C:/myprojects/lattice/xo2picodevelopmentkitsourcecode/Demo_MachXO2_Pico_Environment_Scanning/project/impl1/impl1.xcf""

INFO - Scanning USB2 Port FTUSB-0...
Programmer device database loaded
ERROR - Scan Failed - Creating Blank Programmer Project.
Starting: "pgr_project save "C:/myprojects/lattice/xo2picodevelopmentkitsourcecode/Demo_MachXO2_Pico_Environment_Scanning/project/impl1/impl1.xcf""

ERROR - Failed to Open FTDI USB port. Make sure to select the right cable type.
If you have not installed the FTDI Windows USB Driver, follow the instructions in the Programmer Help topic:
"Installing/Uninstalling Parallel Port Driver and USB Driver".
If you have installed the driver, if you recently plugged in the cable, please wait a few seconds and try again.
This will give the operating system time to recognize the cable.

Starting: "prj_src enable "C:/myprojects/lattice/xo2picodevelopmentkitsourcecode/Demo_MachXO2_Pico_Environment_Scanning/project/impl1/impl1.xcf""



This is the log from the Debug Mode dialogue's Test button:
Code: [Select]
Lattice Semiconductor Corporation.
Diamond Programmer Diamond (64-bit) 3.3.0.109 (Database V3.3.0)

System Information:
-----------------------------------------------------
 Microsoft(R) Windows(R) 8

 64-bit

 Intel(R) Core(TM) i7-3820QM CPU @ 2.70GHz


Error communicating with FTUSB cable.
JTAG_InitDevice function: Invalid device handle.

Failed to Open FTDI USB port. Make sure to select the right cable type.
If you have not installed the FTDI Windows USB Driver, follow the instructions in the Programmer Help topic:
"Installing/Uninstalling Parallel Port Driver and USB Driver".
If you have installed the driver, if you recently plugged in the cable, please wait a few seconds and try again.
This will give the operating system time to recognize the cable.
Cable Auto Detection Activated.
Current LPT Port Mode: Config
(It's recommend that the LPT Port Mode be changed to "SPP" mode by using the Cable and I/O Port Setup->Auto Detect.)
No cable detected at 0x378

Current LPT Port Mode: Config
(It's recommend that the LPT Port Mode be changed to "SPP" mode by using the Cable and I/O Port Setup->Auto Detect.)
No cable detected at 0x278

Current LPT Port Mode: Config
(It's recommend that the LPT Port Mode be changed to "SPP" mode by using the Cable and I/O Port Setup->Auto Detect.)
No cable detected at 0x3bc

No Lattice HW-DLN-3C (parallel) cable detected.
No Lattice HW-USBN-2A cable detected.
Board with FTDI USB Host Chip detected.
Error communicating with FTUSB cable.
JTAG_InitDevice function: Invalid device handle.

Failed to Open FTDI USB port. Make sure to select the right cable type.
If you have not installed the FTDI Windows USB Driver, follow the instructions in the Programmer Help topic:
"Installing/Uninstalling Parallel Port Driver and USB Driver".
If you have installed the driver, if you recently plugged in the cable, please wait a few seconds and try again.
This will give the operating system time to recognize the cable.


I'm going to try it on a couple of VMs (previous tests were on physical hardware), but right now, judging also from a number of other very similar reports both here on Eevblog and elsewhere I think there may be a more fundamental problem.
« Last Edit: December 28, 2014, 01:07:59 pm by Howardlong »
 

Offline mikeselectricstuff

  • Super Contributor
  • ***
  • Posts: 12037
  • Country: gb
    • Mike's Electric Stuff
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #42 on: December 28, 2014, 07:50:47 pm »
I have had issues when there have been other FTDI devices plugged in. Don;t recall details.
Don't bother using the Diamond programmer - use ISPVM - it's typically twice as fast. No idea if it's more or less twitchy than Diamond but I've rarely had any issues with it on XP or Win7

 
Youtube channel:Taking wierd stuff apart. Very apart.
Mike's Electric Stuff: High voltage, vintage electronics etc.
Day Job: Mostly LEDs
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #43 on: December 28, 2014, 09:15:53 pm »
Yes I saw you'd mentioned that earlier, and they were removed, sorry I should have mentioned that.

So, among other things today(!) I installed the same software on three virgin OS install VMs: Windows 7 x86, Windows 8.1 x86 and Windows 8.1 x64. Both x86 installs worked. The x64 doesn't.

So I'd be interested to know if anyone has the Diamond software running under Windows 8.1 x64.

For now though, I guess I'll run it on an x86 VM. Not great, but not a show stopper. All in all a bit rubbish, spent a couple of days on figuring this out, and have yet to write a single line of code.
 

Offline jipihorn

  • Contributor
  • Posts: 18
  • Country: fr
    • jipihorn blog
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #44 on: December 29, 2014, 07:54:45 am »
What a surprise !
I have the same kind of error on a WIN8.1 x64 system with my iCE40 card...

I just received the last answer from Lattice who think I tried to program via JTAG instead of SPI. Except that I did exactly what they explain me to do and they don't seem to understand that it is a usb connection problem.

Sounds like a "dialog of the deaf" (I wonder if this expression is valid).

J.
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #45 on: December 29, 2014, 02:04:31 pm »
Perhaps interestingly the iCEcube2 programming works on my main Windows 8.1 x64 development system, although I do have enforced device signing switched off (for the avoidance of doubt, the MACHXO2 FTDI based programmers don't work).

FWIW, the on-board programmer for the iCEBlink40-HX1K eval board I have is not FTDI, it's an Atmel microcontroller. It enumerates differently on USB in device manager to the MACHXO2 boards I have.

For the MACHXO2, I tried the Lattice Diamond IDE on Windows 8 x64, that didn't work either. Looks like there's a problem in at least Windows 8/8.1 with the Lattice Diamond 3.3 x64 version.
 

Offline jipihorn

  • Contributor
  • Posts: 18
  • Country: fr
    • jipihorn blog
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #46 on: January 02, 2015, 09:26:27 am »
I got a new response from lattice about a problem of compatibility of the Diamond 3.3 programmer and windows 8.1.
They sent me a link to the previous version (3.2) with only the programmer, not the whole Diamond stuff and it works now.

So, no problem with X64 machines as long as you use the 3.2 version, until they fix the last one for windows 8.1.

Jerome.
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #47 on: January 02, 2015, 10:46:26 pm »
Doh! Another few hours of our lives lost. Thank you for the update and link, appreciated.
 

Offline tmbinc

  • Regular Contributor
  • *
  • Posts: 178
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #48 on: January 05, 2015, 08:31:01 pm »
Yay! Thank you very much!

Had the same "JTAG_InitDevice function: Invalid device handle." on the LatticeECP3 Versa, and indeed, programmer 3.2 does work. For reference, it's FTUSB-0 on that board (channel 1 is the serial port connected to the FPGA).
 

Online Howardlong

  • Super Contributor
  • ***
  • Posts: 4778
  • Country: gb
Re: Anyone used Lattice ICE40 FPGAs ?
« Reply #49 on: January 05, 2015, 09:25:43 pm »
Yes, I can confirm that on Windows 8.1 x64, the standalone 3.2 programmer software works with the MACHXO2 breakout board and the MACHXO2 Pico board, both use integrated FTDI programmers.

Sadly, the 3.3 IDE integrated programmer still doesn't work, not sure if it's possible to either integrate the 3.2 programmer with the 3.3 IDE (I did try copying a few DLLs from one to the other but I've since undone that, it was causing more problems than solutions), or if it's possible to get the 3.2 IDE. I have been unable to find archived versions on their website which is unfortunate.

Either way, it seems that we can safely conclude that something's regressed in the 3.3 Lattice Diamond IDE for Windows x64 versions. Regretfully, therefore, it's not been a good start for me with Lattice :-(

Good work everyone for figuring this out!
« Last Edit: January 05, 2015, 09:31:33 pm by Howardlong »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf