Electronics > Microcontrollers

Arduino Ethernet shield help


Recently I bought an Ethernet shield for my arduino UNO board and am having troubles getting it to work correctly. I will let you know that I am a beginner at microcontrolers but I do know all the basics of the arduino code. I have programmed things like led cubes and infrared controllers and other little projects that's about top notch for me as of now. There are several problems I think there could be.  I am using an official arduino board but an off brand ekitszone Ethernet shield. This shield used the enc28j60 Ethernet chip and the official arduino shield uses a different one. I feel this is the reason the examples from arduino don't work for this shield. I did some research and can't find any good code to get this board running. I would like to get it running a simple web server or web client. Any help or suggestions from some of you who specialize in this area would be greatly appreciated. Thanks,


The ENC28J60 chip based shields isn't compatible with the (official arduino) Wiznet W5100 based shields.

There are a few arduino libaries around for using for the ENC28J60. It would be best to search the arduino forums.

The ENC28J60 doesn't have the TCP/IP stack built into the hardware like the Wiznet, so the cost is it takes a lot more effort and SRAM on the arduino to run it, as you have to implement it in your code/library. But it's still usable for small applications.

Here is a library:


I don't know if this is the same shield as yours, if not you'll have to check your Chip/Slave Select line is configured right.

andyg, my shield is somewhat similar. It is made by the same people but i think its a newer version. The HanRun sticker is the same HR911105A the second line reads 11/16 though (I don't think this matters). The one i have looks to be laid out a bit different and has an sd card slot built in it.  I tried the codes from the website and they opened but they had errors when I compiled them. Some code was not recognized or typed right?  I tried to make some adjustments to the code, but as I said the ethernet codes are new to me and a little advanced for me to identify exactly where the error is.

Did you install the library properly, i.e copy the EtherShield directory into the libraries folder in your arduino install? If done properly, the example projects should show up in the menu system with the rest of them.


[0] Message Index

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod