Author Topic: MPLAB X Migration  (Read 2190 times)

0 Members and 1 Guest are viewing this topic.

Offline itdontgo

  • Regular Contributor
  • *
  • Posts: 167
  • Country: gb
    • IoT Manufacturer
MPLAB X Migration
« on: August 05, 2012, 02:08:45 pm »
Hi,

I found a bug with the PICkit3 and MPLAB v8 so took the plunge and installed MPLAB X.

My first impressions were that it had a whiff of the kids toys about it; a bit like when I went from W2K to XP.  I suppose I got used to it.

The big disappointment was that I'm too busy to play games trying to figure out the new features and realised instantly my v8 projects wont load.  Do I have to start a new project and build my asm files etc... or is there a quick way?

Michael

Offline djsb

  • Frequent Contributor
  • **
  • Posts: 723
  • Country: gb
Re: MPLAB X Migration
« Reply #1 on: August 05, 2012, 02:15:33 pm »
You can use the link to the import wizard on the introductory screen for V8 projects. This works OK apart from a couple of warning messages (which I ignore-maybe unwisely). The hex file produced can be a bit difficult to find as it's not put in the same directory as the projects source file. Easy enough to search for by file extension and date stamp though. I've opened and compiled CCS C based V8 projects and they have worked fine. I use XP so YMMV with W7.

David.
David
Hertfordshire,UK
 University Electronics Technician, London PIC,CCS C,Arduino,Kicad, Altium Designer,LPKF S103,S62 Operator, Electronics instructor.  http://debuggingrules.com/ Give a man a fish and you feed him for a day. Teach a man to fish and you feed him for a lifetime.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf