Electronics > Microcontrollers

Bad microcontroller memory

(1/3) > >>

I'm using a Silicon Labs c8051f124 microcontroller.
Here are my symptoms:
When I tried downloading my code, the Silabs IDE returned a message that the "CRC comparison failed'.
Next I tried a "Memory Fill" to fill the memory with all ones, and it failed too. When I checked the memory map a certain area of the memory doesn't get written.
I next tried another board and it worked fine.

My conclusion:
I have a bad flash memory in my microcontroller, and should swap out the chip.

Does anyone have other ideas?

Curious results during flashing ==> Check check double check all your supply voltages. And your programmer. ;)

you tried another board : identical board ? in that case the microcontroller could be bad.
check for missing decoupling caps close to the cpu. during flash the cpu neds to create the program voltage and draws peak currents. if the local decoupling caps are missing you can get flash program errors

Thank you for your responses

Yes I tried two different (identical) debug adapters and 3 identical boards, Only one board gave me the problem.
I will check the decoupling caps, although the same addresses go bad every time.

The chip is most likely bad, replace it.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod