Author Topic: Bricked SAMD21 (not detected by Atmel Ice)  (Read 194 times)

0 Members and 1 Guest are viewing this topic.

Offline 3dgeo

  • Regular Contributor
  • *
  • Posts: 202
  • Country: au
Bricked SAMD21 (not detected by Atmel Ice)
« on: October 06, 2019, 01:33:58 pm »
Hi,

I made custom PCB design that uses SAMD21G18A, first PCB I soldered SAMD21 and most other components of my circuit seems to work. But after having some IO issues I made another PCB with minimum components just to run SAMD21 chip itself (see image below). I burned Adafruit bootloader using Atmel ICE, but chip somehow got bricked, Atmel ICE no longer detects it. I made another PCB, same, tho on 3rd one I think I even haven't chance to burn bootloader.
I know connections are fine and Atmel Ice is working, I still can read my first BCB. I was wondering what could cause this? Are these chips are that sensitive? I don't believe I fried them while soldering, especially when I burned bootloader to 2nd PCB. Most likely I will abandon SAMD21 for other reasons, but still, I need to know what's the problem.

EDIT: Solved, problem was that VDDANA was not connected to 3.3v
« Last Edit: October 06, 2019, 06:31:46 pm by 3dgeo »
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 5944
  • Country: us
    • Personal site
Re: Bricked SAMD21 (not detected by Atmel Ice)
« Reply #1 on: October 06, 2019, 05:30:45 pm »
What does AS error message say exactly?

Try with this tool https://github.com/ataradov/edbg and see what the output is.

You need to at least short L61. You can't leave VDDANA unpowered at all.

No, those chips are not sensitive at all. I work with them all day long without any sort of care, and have note killed one.
Alex
 

Offline 3dgeo

  • Regular Contributor
  • *
  • Posts: 202
  • Country: au
Re: Bricked SAMD21 (not detected by Atmel Ice)
« Reply #2 on: October 06, 2019, 06:01:17 pm »
You have tools for everything, aren't you?  ;D
Can your tool fix this error?

You need to at least short L61. You can't leave VDDANA unpowered at all.
Yah, I looked to other designs and they connect 3.3v directly to VDDANA, but I ignored that cos my first board works without it, but I can bet that's my problem, iron heating up, will know in a sec... It might be the answer to my Reset problem as well.
« Last Edit: October 06, 2019, 06:32:19 pm by 3dgeo »
 

Offline ataradov

  • Super Contributor
  • ***
  • Posts: 5944
  • Country: us
    • Personal site
Re: Bricked SAMD21 (not detected by Atmel Ice)
« Reply #3 on: October 06, 2019, 06:03:49 pm »
Is this with VDDANA connected? Because if not, then there is nothing to fix, the chip is not supposed to work with this voltage missing.

The reason I'm suggesting my tool is that it may produce a better error message.
Alex
 
The following users thanked this post: 3dgeo

Offline 3dgeo

  • Regular Contributor
  • *
  • Posts: 202
  • Country: au
Re: Bricked SAMD21 (not detected by Atmel Ice)
« Reply #4 on: October 06, 2019, 06:16:40 pm »
Yep, now it works, idiot me...  :palm:
Tho Reset issues still there with 1st board.
« Last Edit: October 06, 2019, 06:33:04 pm by 3dgeo »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf