Electronics > Microcontrollers

Help with compiling git repository

(1/1)

ryano12:
Hi There, I've put together my own hardware based on the info in the github repository https://github.com/d-ronin/openlager
I've now assembled my PCB's and am trying to build the firmware/loader to flash to my STM32 based hardware.

I am terrible at anything to do with code but I've tried several methods to build the firmware, but immediately with the error;

--- Code: ---Makefile:6: *** **ERROR** ARM-SDK is not in tools/gcc-arm-none-eabi-5_2-2015q4.  Stop.
"make -k all" terminated with exit code 2. Build might be incomplete.
--- End code ---

I've been through hours of youtube and platforms but all with the same result.. I've downloaded and installed the latest GNU gcc-arm toolchains ( https://developer.arm.com/tools-and-software/open-source-software/developer-tools/gnu-toolchain/gnu-rm/downloads ). I've tried altering the makefile code to reflect the "gcc-arm-none-eabi-10.3-2021.10" toolchain that I've installed but cannot get anywhere with it.

I've tried with VS-Code, STM32CubeIDE and been as far as installing a virtual linux system with XBUNTU and end up with the same result (lack of user knowledge/PEBKAC)

Is there anyone that can help me build the .bin files for this bootloader to be flashed to my hardware?

Pics of hardware, if it's of interest... It's the first PCB i've ever made, but the magic smoke remains inside and I can see the empty chip flash on the chip in the ST-Link utility.
It's a 20x20mm board that is intended to be used as a logging peripheral for quadcopter blackbox logs. The flight-controller's onboard flash and logging is limited to 16mb which equates to about 4 minutes of flight time at 4khz sampling.. This device should be able to log for hours at much higher rates.
(Learnt my lesson with ignoring JLCPCB's silk screen capabilities)

abyrvalg:
The project expects ARM GCC to be installed in a local dir ./tools/gcc-arm-none-eabi-5_2-2015q4/. You can do one of these things:

1. To use "system-wide" (accessible via $PATH) arm-none-eabi-gcc just set the ARM_SDK_PREFIX to arm-none-eabi- and comment out the error check like this:

--- Code: ---ARM_SDK_PREFIX := arm-none-eabi-

#ifeq ("$(wildcard $(ARM_SDK_PREFIX)gcc*)","")
#    $(error **ERROR** ARM-SDK is not in $(ARM_SDK_DIR))
#endif

--- End code ---

2. To use some specific ARM GCC installation (neither in $PATH nor in ./tools) specify a full (not $TOOLS_DIR-relative) path to it like this:

--- Code: ---ARM_SDK_DIR := ~/electro/ARM/gcc-arm-none-eabi-10-2020-q4-major

--- End code ---

ryano12:
That worked! Really appreciate the help!!!

Navigation

[0] Message Index

There was an error while thanking
Thanking...
Go to full version