Electronics > Microcontrollers

I think my ICD3 is shagged

(1/4) > >>

Pineapple Dan:
I can still use it to program the chip but only the first time I launch MPLAB-X otherwise I get "failed to program device". If I change some setting prior to programming it always works such as changing from 'Allow ICD3 to select memories to program' to 'manually select memories and ranges' it also works

Debug plain doesn't work.

Have installed mplab on 2 other computing machines and same problem. Mplab IPE does allow me to program multiple devices in succession without changing settings. Any ideas before I horse it into the bin?

I changed from PIC16 to PIC8 and back to make it re-load firmware/fpga and it spewed out loads of errors but did eventually load them, however upon going back to pic16 which I am using now it does the same thing. Have tried a couple of PIC16 chips to rule out that it's the chip.

AaronLee:
Try to manually reprogram the firmware in the ICD3. Don't trust MPLAB to do it correctly automatically. You may need to unplug the USB cable after completing and the plug it back it. It's very temperamental. Also, if you use a combination of the old MPLAB and MPLABX, you may need to use the driver switcher utility to get it to work correctly. Those two points are what typically caused me headaches with the ICD3 in the past. If all else fails, reboot your PC and again manually reprogram the firmware.

fcb:
Try MPLAB 8.92 (before MPLAB X) before you consign it to the circular file.

NorthGuy:
Looks like a bug in MPLAB X to me. Try few different versions, including older ones, especially if your PIC16 is old. For each version you may need to update the firmware, as it changes from version to version.

SiliconWizard:
I would first try with a different version of MPLAB X, and/or MPLAB 8.xx as suggested above, before anything else.

If the same still happens... then I dunno. The hardware may be borked in some way? I've seen ICD3 and ICD4 interfaces go flaky too. AFAIR, Microchip wasn't too difficult to deal with and would replace them relatively easily. Dunno if that's still the case.

But I'm definitely glad I do not use Microchip parts anymore. And to think I was still almost "swearing" by them a few years ago. But dev tools really started annoying the heck out of me.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version