Author Topic: ILI9486, SPI and RGB565  (Read 581 times)

0 Members and 1 Guest are viewing this topic.

Offline madires

  • Super Contributor
  • ***
  • Posts: 6153
  • Country: de
  • A qualified hobbyist ;)
ILI9486, SPI and RGB565
« on: June 27, 2020, 03:43:48 pm »
Does someone have experience with using ILI9486 based displays? The datasheet notes that only RGB111 and RGB666 color schemes are available when the SPI interface is selected. But I've seen some code using RGB565 with the SPI interface. So I wonder if the datasheet is correct or not. Unfortunately I don't have an ILI9486 display module with SPI interface for testing and I'd like to keep my module with an 8-bit parallel bus unmodified.
 

Offline dave j

  • Regular Contributor
  • *
  • Posts: 87
  • Country: gb
Re: ILI9486, SPI and RGB565
« Reply #1 on: June 27, 2020, 04:10:27 pm »
Does someone have experience with using ILI9486 based displays? The datasheet notes that only RGB111 and RGB666 color schemes are available when the SPI interface is selected. But I've seen some code using RGB565 with the SPI interface. So I wonder if the datasheet is correct or not. Unfortunately I don't have an ILI9486 display module with SPI interface for testing and I'd like to keep my module with an 8-bit parallel bus unmodified.

Going by this thread on github the datasheet is correct. See this post for confirmation.
I'm not David L Jones. Apparently I actually do have to point this out.
 
The following users thanked this post: madires

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 7165
  • Country: fr
Re: ILI9486, SPI and RGB565
« Reply #2 on: June 17, 2021, 06:17:37 pm »
Ah, I just happen to be wondering the exact same thing. I have received a couple of those 480x320 panels with an ILI9486 controller, and from the DS, I got the same thing as you did, but I've also seen source code that would still use 16bpp data using SPI. I guess those libs are all bogus?

Have you finally gotten this to work, and if so, what format did you use?
 

Offline madires

  • Super Contributor
  • ***
  • Posts: 6153
  • Country: de
  • A qualified hobbyist ;)
Re: ILI9486, SPI and RGB565
« Reply #3 on: June 17, 2021, 07:27:38 pm »
Seems so. For SPI I use RGB666.
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 7165
  • Country: fr
Re: ILI9486, SPI and RGB565
« Reply #4 on: June 17, 2021, 08:09:11 pm »
OK, that's what I'm implementing. What clock rate did you use for SPI? From the DS, looks like 16MHz would be the maximum.
 

Offline madires

  • Super Contributor
  • ***
  • Posts: 6153
  • Country: de
  • A qualified hobbyist ;)
Re: ILI9486, SPI and RGB565
« Reply #5 on: June 17, 2021, 08:30:00 pm »
Just 8 MHz, but I wouldn't be surprised if you can go higher than 16 MHz.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf