Electronics > Microcontrollers

Is ST Cube IDE a piece of buggy crap?

<< < (204/205) > >>

paulca:
I just fresh installed Cube on Windows 10.

I cloned an old (year) project from git and opened the IOC.  It said I could upgrade it, so I said, "Aye on ya go then."

Then I hit Run.  Did the your STLink has a new firmware dance and .... it worked.

It worked.  Just worked.

Nothing to report here, nothing to see.

peter-h:
Yes; apart from Cube IDE occassionally changing the GCC tool version and introducing different default compiler/linker options which bring up new warnings, I have found Cube updates to "just work".

Occassionally I uninstall Cube totally and reinstall fresh, just to make sure.

zapta:
>> a macro which contains a return() will obviously blow it up, because the mutex will never get released

If you use C++, you can define mutexes that release automatically when leaving their scope. Very handy and safe IMO. Example:

https://github.com/zapta/daq/blob/main/controller/platformio/lib/data_queue/data_queue.cpp#L98

zapta:
TL;DR, using CubeIDE for configuration only and platformio for the rest.

A few months ago I started a STM32H7 project and had a dillema which IDE to use. My favorite IDE is platformio, for all MCUs, but realized the value of the CubeIDE value in generating the initial and updated configuration code from the .ioc file. As a result I setup an environment with a combination of the two. A CubeIDE project is used only for editing the .ioc file and generating the code, with no manual editing whatsoever, and a platformio project is used for the rest of the code development. I use a small python script to automatically update the platformio library when I make configuration changes in the CubeIDE project.

Overall it works great for me, being able to use the CubeIDE configurator with the platformio project.

This is the python script I am using. It does a few patches to the CubeIDE code to simplify having a separation between the CubeIDe files and the code files I edit in platformio.

https://github.com/zapta/daq/blob/main/controller/cube_ide/update_platformio.py

peter-h:
Just updated Cube IDE from v13 to v14 and the binary generated is identical. So thankfully they haven't changed the tools.

The random file opening issue (basically when you stop a running project, breakpoint, etc, a random .c file gets opened) has not been fixed. It still opens whichever .c file the CPU was executing at the time, which tends to be some bit of FreeRTOS in my case. The way to solve this has been worked out and documented but clearly ST don't want to do it.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version
Powered by SMFPacks Advanced Attachments Uploader Mod