Electronics > Microcontrollers

Need help dumping the ROM in a failing 80C49 (MCS-48)

<< < (11/11)

Nevermind! All good again. Deep clean with IPA and brush solved it.

[old text]
The weirdest thing just happened:
The Arduino shield doesn't do EA above 4.4V anymore.
It's supposed to do 4.4V, 12V and 18V.

One of the transistors gone possibly?

Schematics here: http://www.mattmillman.com/wp-content/files/mcs48programmer.pdf
[/old text]

Another discovery: EA is actually pulled rather high actually, about 12.9V on my DMM, and there is a spike at the start also.
I've included the screenshot I did to compare EA enable and Reset to check for a dump start before EA was stable.
That may explain why the 8749 has no issues, where the 8049 should have a very close to 12V applied.
Could this be an explanation for the freakout / noisy waveforms?
I could try to lift EA and apply directly from the shields Vin from Arduino, giving a continuous stable 11.5V.

It still doesn't explain why there is no 5V idle on the 8049 Databus though.

I'm tempted to do a basic breadboard version as done here: http://qemulator.blogspot.com/2020/05/dumping-intel-8049-roms.html
Should have more control over voltages and such.

The second MCU from Japan is verified in the unit I'm repairing, so that is a relief at least.

I tried to lift Vin and apply directly to EA.
Now the arduino shield is no longer detected :S :S :S
My impatience is starting to show.

Nevermind again!
Shield and arduino fully working.
I panicked when all of a sudden the default COM port was changed in the HvEprom app.


[0] Message Index

[*] Previous page

There was an error while thanking
Go to full version