Electronics > Microcontrollers

Poweron problems using PIC and automotive application

(1/4) > >>

mtechmatt:
Chaps,

The circuit is as shown in the attachment...

The processor is a PIC18F8520. It takes Vcc for power (5v) and also the MCLR line from the circuit as atatched.

What happens is on the test rig its fine, but sometimes on the car, the MCU doesent come to life, which I believe to be a MCLR issue. Turning the key off and on again (switching off the RAW 12v) will then bring the board back alive. 5v is present on the rail regardless so I know the PSU is coming to life OK, just think something is causing the processor not to boot corrrectly

Does anyone have any suggestions as to a better MCLR circuit, or a better PSU that would helo solve this issue?

Beer tokens via paypal to the winner as I am at my wits end with this one!!

Cheers
Matt

PeterG:
One thing to keep in mind is that automotive power is one of the noisiest dc power sources out there. I have had issues where there were spikes coming in through the io lines or the voltage reg. If possible look at the 5v rail when the car starts. There may be noise coming in causing the mcu to crash.

Regards

mtechmatt:
Peter,

Thanks I will put the scope on the car tomorrow and see what we get.

Did you by any chance come to a decent supply design in the end?

Thanks,
Matt

Short Circuit:
Do you have bulk capacitance between VCC and GND? The inductor will filter current transients, but without sufficient capacitance, this means drop in VCC.
Also for a transient sensitive environment, it might be better to use a real reset generator instead of a simple RC. The MCLR may not drop below Vil during a short voltage dip.

mtechmatt:
Short Circuit,

I have 100ns scattered about plus one near each of the power pins of the MCU, to help with stabilisation.

Its not an issue once the car is running, even with severe noise (we have held the PCB next to the coil pack and noticed induced noise on the trigger lines but its not causing MCU reset.)

I think the real problem lies with the MCLR reset on power on not transienting correctly.

Can you reccomend a circuit for the reset circuit please? Is there an IC or would a simple bistable with a trabnsisotr do it?

Regards
Matt

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version