Author Topic: Trouble with FTDI adapter  (Read 761 times)

0 Members and 1 Guest are viewing this topic.

Offline Dan Moos

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Trouble with FTDI adapter
« on: April 01, 2017, 09:00:33 pm »
Ok, first off, I'm not thinking this is the usual FTDI fiasco thing.

I have this:

http://www.mouser.com/ProductDetail/FTDI/DB9-USB-D5-M/?qs=sGAEpiMZZMuhucAexPYLelnvPR1J%2fIyQ

I have successfully gotten data out of my project (6502 based computer build), into a terminal program. Data from my project's UART  displays uncorrupted in the terminal.

I can't seem to get the adapter to send data OUT FROM the PC. I have a scope probe on the appropriate pin (RxD on the part) and it just sits HIGH and inactive when I type in the terminal.

To avoid some misunderstanding that i had in another forum that is also helping me, I for sure don't need a NULL modem connection. Look at the datasheet. I have the MALE part. So when sending data FROM the PC, it should appear at the adapter's RxD pin.

I've tried a loopback connection, with RxD and TxD tied together, and nothing. I have yet to be able to create any activity on the RxD pin, whilst data going the other way (which requires my homebrew computer build to run a program, access the UART, and all of that) works fine. Yet a simple use of the terminal to get something to happen on the RxD pin of the adapter has stymied me.

I have all handshaking and flow control OFF in the terminal. I have the right port settings. I'm going for 8,1,none, but even if that was wrong, a loopback should work. I'd at least get SOMETHING.

I'm not even trying to involve my projects UART yet. I'm trying to intercept the data just before it reaches it, so any complications with my UART code/connections are not part of the problem.

I'm actually wondering if its a driver issue. My driver is up to date, or so Windows claims.

I've tried RealTerm, TerraTerm, and Putty. I've tried more than one USB cable, and port on the PC.

My Bus Pirate, which also uses an FTDI to USB connection works just fine.

My understanding of the FTDI driver shenanigans is that you either get garbage, or an unrecognized device. I get a re4cognized device, good data one way, and zero activity the other. That's why I don't think its an FTDI anti-counterfeiting issue. That said, I admit a limited amount of knowledge on this matter.

I'm at my wit's end! Help!
 

Online kripton2035

  • Super Contributor
  • ***
  • Posts: 1901
  • Country: fr
    • kripton2035 schematics repository
Re: Trouble with FTDI adapter
« Reply #1 on: April 01, 2017, 10:25:19 pm »
since the fdti driver "problem", I bought some usb-uart bridges from another brands (cp2102, or chg340)
and if I suspect such driver problem, I check with these other bridges.
ps: finally, I end up using the others chips as they are really less expensive, and are ok for the job.

Offline Dan Moos

  • Frequent Contributor
  • **
  • Posts: 254
  • Country: us
Re: Trouble with FTDI adapter
« Reply #2 on: April 02, 2017, 04:18:15 am »
Solved! Stand down.

I'm a dumbass who reads datasheets backwards.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf