Products > Networking & Wireless

Cisco SPA 122 glitchy firmware


I was told to upgrade the firmware so I thought I use the latest on one.

Being a bit of Cisco gear I didn't expect there to be the issues that I have experienced below.
Two units, one with 1.3.5 and the other with 1.3.1 firmware worked perfectly fine work a week with no problems.

Updated to 1.4.1 SR5 firmware:

Noticed high CPU usage for both on the SNMP.
Both disappears off the LAN, 7 and 9 hours later and become unreachable even with the power cycled.
Had to preset factory reset button and set them back up.
This time made a backup of the config for both.
Noticed: It logs out randomly from the built in webserver and does it everytime after downloading the config and it didn't do it before the update.
It happened again on both at different times dropping of the LAN.
Router syslog shows traffic from the WAN port to Cisco NTP servers and dns.
The syslog before they stopped doesn't seem to show any change to cause this to happen.
I reset it, upload config, and it failed to upload.
It's not the browser as tried three, Vivaldi (Chrome 90, Palemoon, and Internet Explorer 11)

I started to suspect something is wrong.

Could it be I didn't apply updates before in a sequence like with some of Netgear stuff. I checked but I don't see anything in the manual.

Anyway I found the firmware and put the it back on 1.3.5 and 1.3.1 the way it was before. I was a bit worried at first whether this glitch could cause the firmware fail during upload but didn't and notice they do have backup roms.

Set it back up no issue. I can download config without them logging out and upload it, it doesn't drop off.

I tested it and worked my way up to 1.4.1 and 1.4.1SR1 and the problems started with 1.4.1 SR2 with it failing to upload the config and 1.4.1 (SR5) and it logs out after the config or randomly when trying to change settings.

I noticed this:

--- Quote ---Firmware for SPA112 and SPA122, Version 1.4.1 SR5   04-Nov-2019
Firmware for SPA112 and SPA122, Version 1.4.1 SR4   23-Jul-2019
Firmware for SPA112 and SPA122, Version 1.4.1 SR3   23-Apr-2019
Unreleased  SR2?
Firmware for SPA112 and SPA122, Version 1.4.1 SR1   15-Aug-2017
Firmware for SPA112 and SPA122, Version 1.4.1       24-Nov-2015
Firmware for SPA112 and SPA122, Version 1.4.0       28-Jul-2015
Firmware for SPA112 and SPA122, Version 1.3.5       24-Jul-2015
--- End quote ---

It appears to me like they messed something up in SR2, possibly withdrew it and tried to fix it a couple of times seeing the same firmware version and I believe SR may mean "service release?".

In the notes it was what I expect about issues like this and to check on their Cisco bug search.

Access Cisco Bug Search

As soon as I try to make an account it goes to another sub domain and the portal is not recognizing the credentials then it redirects somewhere else with a message that the address has changed and to update the bookmark. I didn't find anything about these issues on the search engines and I can't even check on the Bug search.

Maybe it's old the bug check is old or doesn't exist and not looking in the right place.

Messing something up and not fixing it with the last one being the worst very disappointing coming from Cisco.

So far they seem fine with 1.4.1 sr1 release and haven't dropped off yet.

Does anyone use Cisco analogue phone adapters and experienced these issues before after the firmware update?


[0] Message Index

There was an error while thanking
Go to full version