Author Topic: Firefox 112: broken?  (Read 7747 times)

0 Members and 1 Guest are viewing this topic.

Offline madiresTopic starter

  • Super Contributor
  • ***
  • Posts: 7876
  • Country: de
  • A qualified hobbyist ;)
Firefox 112: broken?
« on: April 12, 2023, 12:32:05 pm »
After updating Firefox to v112 (linux) and visiting the EEVblog forum I've noticed that input fields display spaces instead of text. For example, at login the field for the username doesn't display the characters I type, just spaces instead. Also, when quoting a post the input box appears to be empty, but marking text reveals a lot of spaces. Some other forums have similar issues or even have a totally broken layout (missing elements). New Firefox feature?
 

Online xrunner

  • Super Contributor
  • ***
  • Posts: 7557
  • Country: us
  • hp>Agilent>Keysight>???
Re: Firefox 112: broken?
« Reply #1 on: April 12, 2023, 12:36:28 pm »
Just checked using v112 under linux Mint - no problems here.
I told my friends I could teach them to be funny, but they all just laughed at me.
 

Offline JohanH

  • Frequent Contributor
  • **
  • Posts: 638
  • Country: fi
Re: Firefox 112: broken?
« Reply #2 on: April 12, 2023, 12:39:58 pm »
 

Offline madiresTopic starter

  • Super Contributor
  • ***
  • Posts: 7876
  • Country: de
  • A qualified hobbyist ;)
Re: Firefox 112: broken?
« Reply #3 on: April 12, 2023, 12:53:58 pm »
Thanks for the feedback! Debian 11 here. I've already created a new profile for testing, still same issues.
 

Offline madiresTopic starter

  • Super Contributor
  • ***
  • Posts: 7876
  • Country: de
  • A qualified hobbyist ;)
Re: Firefox 112: broken?
« Reply #4 on: April 12, 2023, 01:04:50 pm »
Found it! When 'Allow pages to choose their own fonts, instead of your selections above' in the font configuration is disabled then things are back to normal, just with my selected fonts.

Edit: I checked this issue also on another PC. Funnily the EEVblog forum is fine but other websites have missing text. However, enforcing my fonts fixes that.
« Last Edit: April 12, 2023, 01:41:39 pm by madires »
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 14682
  • Country: fr
Re: Firefox 112: broken?
« Reply #5 on: April 20, 2023, 07:58:06 pm »
That's because Linux is awfully broken and no one wants to deal with that. :-DD
 
The following users thanked this post: Bryn

Offline JeremyC

  • Regular Contributor
  • *
  • Posts: 148
  • Country: us
Re: Firefox 112: broken?
« Reply #6 on: April 20, 2023, 08:31:06 pm »
The problem is not related to the operating system (Linux), but to Firefox ESR edition and user's custom fonts. The ESR edition is the default in Debian.
« Last Edit: April 20, 2023, 08:34:17 pm by JeremyC »
 

Offline SiliconWizard

  • Super Contributor
  • ***
  • Posts: 14682
  • Country: fr
Re: Firefox 112: broken?
« Reply #7 on: April 20, 2023, 09:07:59 pm »
The problem is not related to the operating system (Linux), but to Firefox ESR edition and user's custom fonts. The ESR edition is the default in Debian.

That was a joke.
 

Offline JeremyC

  • Regular Contributor
  • *
  • Posts: 148
  • Country: us
Re: Firefox 112: broken?
« Reply #8 on: April 20, 2023, 09:22:34 pm »
Ok, I got it, thanks for clarification
 

Offline madiresTopic starter

  • Super Contributor
  • ***
  • Posts: 7876
  • Country: de
  • A qualified hobbyist ;)
Re: Firefox 112: broken?
« Reply #9 on: April 26, 2023, 09:02:07 pm »
It's a bug, fixed in 112.0.2 (https://www.mozilla.org/en-US/firefox/112.0.2/releasenotes/):
Quote
Fixes an issue where Linux users with bitmap fonts installed may have had entire sections of text invisible to them on some sites (bug 1827950).
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf