EEVblog > News/Suggestions/Help

"Online" error

<< < (3/4) > >>

tggzzz:
I saw the "online username" a few days ago. The next page I loaded didn't have it.

More often I see some missing formatting: the background is white, the text is plain, and the content is down the screen without being formatted into boxes. (Just like a retro bulletin board!) Again, the next page loaded correctly.

Whales:
"Online" is the alt text you see when the little image to the left of someone's username doesn't load.

I'm talking about these images:

In the HTML they look like this:

--- Code: ---<img src="https://www.eevblog.com/forum/Themes/default/images/useron.gif" alt="Online" data-pagespeed-url-hash="159412188" onload="pagespeed.CriticalImages.checkImageForCriticality(this);">
--- End code ---

You can manually trigger this "Online" bug by editing the page in your browser (right click page -> Inspect or Edit) and intentionally adding a typo into the image URL, so it can't load.

Possible causes:

(1) URL to image is wrong (unlikely?  but possible if eg "theme" is randomly changing)
(2) Image is not being received by the web browser when requested.  Possibly a forum (PHP?) bug, webserver issue, caching issue, browser issue, your own internet link, could be anything.

Kean:
Dave, I just saw this issue this morning.

Below is the HTML fragment.  The "pagespeed" image URL wasn't valid at the time I viewed the source but seemed to become valid soon after.  :-//


--- Code: ---<a href="https://www.eevblog.com/forum/pm/?sa=send;u=xxxx" title="Online"><img src="https://www.eevblog.com/forum/Themes/default/images/useron.gif.pagespeed.ce.66OcTgBrBO.gif" alt="Online" data-pagespeed-url-hash="159412188" onload="pagespeed.CriticalImages.checkImageForCriticality(this);"/></a>
--- End code ---

Whales:
I think "pagespeed" might be Apache pagespeed?  https://www.modpagespeed.com/doc/filters

Ie configured in the webserver config, not php or simplemachines.

N.B. these optimisation and acceleration programs are heavily situation dependent; they can make things better, worse or not much different at all.  Eg switching out the tiny .gifs on dynamically generated pages might not actually achieve much; but it could be doing stuff elsewhere that helps.  I am innately suspicious of any and all such optimis programs :)

ataradov:
Speaking of things not loading. I just notices that this user https://www.eevblog.com/forum/profile/?u=105798 has avatar picture that leads to URL outside of the eevblog (http://www.unrealitytv.co.uk/wp-content/uploads/2016/01/doctor-who-peter-capaldi.jpg). And that redirects to some spam place that uBlock blocks, or shows a page that offers to buy the domain.

How did this happen? Allowing random links in avatars seems unsafe, but I don't even understand how that is possible.

Ok, I went to check and apparently you can specify URL of an avatar. This is a tracker's wet dream. How is this even an option? This open so many opportunities to mess with the forum. You are allowing people to load any unverified content.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

There was an error while thanking
Thanking...
Go to full version