Electronics > Open Source Hardware

Chinese TC1 transistor tester

(1/3) > >>

Hi guys
I bought this transistor tester from china.
It worked well until I tested a 1000uF capacitor which was discharged. But immediately the instrument TC1 turned off.
I've seen there are other discussions on this machine, but one seems to me not enough discussed.
On my TC1 I tried to search the faulty component and I've found the DZ2 in short circuit.
I removed it and checked every other component around: all seems ok
But if I turn it on, It displays a "ghost battery" of 1,42V applied at terminals 1&2 but of course, there isn't (see images).
Also, if try to measure any component I get always the same image.
If I think to change the microcontroller, is there any firmware available? Where I can download it?
Please let me know, thanks


There are more than a dozen  firmwares available..

Try to check which version matches your hardware
and be careful with the FUSES




The original mamut thread is still alive and well


And new firmware  available with the olders..

Take your time reading stuff


This picture is part of Markus bundle  software package.

It should help you to find a primary reference for your board..

The newest firmware is already in the URI above


I want to thank you PKTKS for your kind answer, I've already tried to download those GITHUB links -but- there's a problem 4 me:
Several of those files, I cant' be downloaded, and, more of all, I don't know how to compile the firmware.
I'm not a programming nerd, so I have difficulties trying to compile these things.
Also you finally suggest to be careful with the programming fuses...
Since those are ALOT fuses inside the microcontroller, I really don't know which is which and their correct configuration I need to set them to be able to program the new microcontroller I bought AND to be able to reprogram it anytime in the future. (In case it will break again)
I'm a simple user of the TC1 tester, not making them in any production... I simply want to repair this valuable tester... don't want to do anything else with it...
Believe me, all this is a mess as it is, from my pov.

I'm not a master in all this, unfortunately.
similarly, that little PCB to replace the U4... I don' have a PC equipped & power enough to handle also kikad to read those files (I already have a mess of applications on my PC, that I use for a lot of other jobs, and don't have enough time to learn new programs.
The electrical scheme of that little PCB would be already enough for me to replicate it.
Consider that I'm 62!
So if you or someone else could link me:
- the already compiled firmware (any version, .hex or .bin) compatible with the U4 hardware PCB modification;
- could tell me how to set the fuses to be able to use the thing, and can read/reprogram it eventually anytime AFTER;
- and finally could give me a screenshot of the schematic to replace U4, I would be TOTALLY GLAD.
That's all I need.
Thanks for the attention.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version