Author Topic: Unable to load firmware for popular TS100 and ES121 tools  (Read 1622 times)

0 Members and 1 Guest are viewing this topic.

Offline kmpres

  • Newbie
  • Posts: 2
  • Country: us
Unable to load firmware for popular TS100 and ES121 tools
« on: May 04, 2019, 05:04:28 pm »
Hi Guys,

First post here.  I have what sounds like an easy question but it took far too much time from my day today and I still have no answer.  So, maybe you can help.
I recently bought a new TS100 soldering iron and as ES121 electric screw driver from Banggood.  They both work fine but I have been unable to load any firmware into them.  All the websites I've tried ( and several others) give "This site can't be reached" errors and the devices don't connect to my two computers despite engaging their config modes and using three different USB ports and three USB cables.  Not even the little USB jingle comes up when the connector is plugged in.  And yet both computers work fine with other devices, like my camcorder and bluetooth keyboards, and my internet connection is not restricted in any way that I am aware.  One computer is a 10 year old desktop but has a fresh copy of Win 10 installed, the other is a new HP laptop with Win 10 installed.  I do use a VPN but turning it off has had no effect.  Getting tech support has also been ridiculous - as usual, nobody is manning the websites these days.  Have any of you run into these difficulties?


Online Gyro

  • Super Contributor
  • ***
  • Posts: 7774
  • Country: gb
Re: Unable to load firmware for popular TS100 and ES121 tools
« Reply #1 on: May 04, 2019, 06:47:19 pm »

I can't help you with the ES121 but on the TS100 you need to hold down the button closest to the tip while plugging in to get into USB mode. It should then show up as an external memory drive.
Regards, Chris

"Victor Meldrew, the Crimson Avenger!"

Offline kmpres

  • Newbie
  • Posts: 2
  • Country: us
Re: Unable to load firmware for popular TS100 and ES121 tools
« Reply #2 on: May 30, 2019, 03:19:11 pm »
Sorry for the delay in getting back to you on this.  Life intervention you know. 

Re: my problem, no matter what I do, Windows 10 will not acknowledge the presence of either my ES-121 screwdriver or my TS-100 soldering iron.  As far as my computers go, they are dead products and no firmware exists for them.  Two computers, three USB cables and all manner of pressed buttons before and after insertion were tried with the same result each time.  I think some third party sites are accessible, but if my devices can't connect to my USB ports then any attempt to load firmware into them isn't possible.  This includes the site listed in the instructions,, which keeps giving me "unable to connect" messages.  Simply plugging the devices into my USB ports should have done something, but I get nothing.  Have any of you seen this problem?  What am I missing here?

Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo