Computing > Programming

Trouble adding existing files to project in Atmel Studio 5.1 - FIXED

(1/2) > >>

basinstreetdesign:
I have 4 C files that make a project for the ATMEGA16 and am using Studio5.1 to compile them but it will compile only 1 file and ignores the rest. Can anybody suggest what I can do to add the other 3 files to the program so that they are compiled and linked?

MIS42N:
Is that version 10 years old or more? Maybe a later version will work for you. https://www.avrfreaks.net/forum/if-you-have-problem-5661-upgrade-62?name=PNphpBB2&file=viewtopic&t=124239

basinstreetdesign:
I just finished a project using this compiler and it had 5 source files.  No problem compiling the lot and producing the *elf file to download to the target.  But now with a new project it can see only one file, the one with main{} in it.  I used the >FILE>NEW>FILE menu command to create files as I thought I had before, and it will do so but the compiler ignores them.  Its running on a Win XP machine I have just for programs like this.

Psi:
Have you added all the extra files to the project?
The IDE needs to know to add them to the makefile.

Syntax Error:
Nothing wrong with XP :)

I suspect you may need to first convert the other files into shared libraries(?) A bit about this:
https://www.cprogramming.com/tutorial/shared-libraries-linux-gcc.html
And on importing precompiled libraries into AS
https://www.avrfreaks.net/forum/how-import-libraries-my-project-atmel-studio-7

To help, make sure the files are in the same directory as main.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version