Author Topic: PHY Link only establishing 10 Mbps speed when both devices 100 Mbps capable  (Read 408 times)

0 Members and 1 Guest are viewing this topic.

Offline vpanchal

  • Newbie
  • Posts: 1
  • Country: ca
Hi all,

I've designed a circuit board with a Microchip switch (KSZ9897) going to a Ethernet-to-VDSL module (LX200V20).

The PHY ports between the two devices are connected using a transformerless connection as shown on Figure 4 in this application note (http://ww1.microchip.com/downloads/en/AppNotes/ANLAN120-UNG.pdf).

By default with auto-negotiation & auto MDI-X enabled, the switch establishes a 10 Mbps, full-duplex link. I am expecting a 100 Mbps link since both devices are 100-BaseTX compatible and I've confirmed that by decoding the LCW (link-code-word) from their fast link pulses.

I have also tried a forced speed connection (disabling auto-negotiation). For 100 Mbps & Full-duplex, I can see some idle traffic on both RX and TX pairs, but the link does not come up. For 10 Mbps & Full-duplex, the link does come up and work. I have also tried disabling auto MDI-X, but that does not seem to change much either.

My question is what could be causing the link to only establish at 10 Mbps? I have attached some scope pics to help isolate the problem. The scopes are all from one of the RX/TX pairs between the switch and the AC coupling caps.

Scope 1) Forced 100 Mbps idle traffic
Scope 2) LCW from VDSL module (left burst), LCW from switch (right burst)
Scope 3) NLP (single burst of LCW) from VDSL module

Any help is appreciated!
 

Offline ajb

  • Super Contributor
  • ***
  • Posts: 1874
  • Country: us
Can we see your layout?

What does the modem say about its ethernet pins, are they internally or externally terminated?

Have you checked the errata for the switch?  Some of them have weird issues that only show up in certain conditions or with certain link partners.
 

Offline David Hess

  • Super Contributor
  • ***
  • Posts: 12434
  • Country: us
  • DavidH
10Base-T and 100Base-T use the same interface wiring but 100Base-T will fail if the two pairs are not good transmission lines.  I usually see this when someone wires an Ethernet cable straight through.
 

Offline AndyC_772

  • Super Contributor
  • ***
  • Posts: 3750
  • Country: gb
  • Professional design engineer
    • Cawte Engineering | Reliable Electronics
Can you post the relevant portion of your schematic?

Are you 100% sure you've got the correct termination scheme for the two PHYs in use?

The scope trace for forced 100M looks horrible, no way that's a correct 100M Ethernet waveform. You should be seeing very clean, symmetrical half-sine pulses at 125 MHz, but it looks like the bandwidth of your signal is quite severely limited for some reason. (What's the bandwidth of your scope, and are you probing the signal correctly?)

I suspect a 50R resistor or two somewhere will work wonders.


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf