Electronics > Projects, Designs, and Technical Stuff

AM2732B and TL866ii+

(1/2) > >>

Wawavoun:
Hello there,

I have two AM2732B eprom. I assume they are not counterfeit because writing is acetone resistant...

The marking say "12.5V pgm", datasheet say same, so TL866ii+ should do the job !

They are in the supported ic list and after selecting Xgpro parameters look good (VPP 13V, VDD write 6.5 V, VCC verify 5 V, pulse delay 500 µs).

Pin detect, blank check  and reading work well.

But there is no way to program these eprom.
Immediately after writing sequence start I got the message "Program failed". No progress bar etc....
Log file don't give any valuable information.
The problem is the same on both eprom, also under windows 10 or linux+wine.
With a pulse delay of 1 ms problem is the same.

Anything I can try to improve the situation ?

Also : what means "VDD write" and "VCC verify" into Xgpro ?

Thanks for your advice.
Philippe


Wawavoun:
I just give a try with minipro.

I notice that after more or less 6 trys with pulse at 12500 µs the error switch to the second byte... Repeating again 6 trys and the error then switch to byte 3...

So now I will run minipro without verification (so it goes to eprom end even with error) and I will do that 10 times for security...

Will see...

wraper:

--- Quote from: Wawavoun on April 13, 2021, 04:04:21 pm ---I assume they are not counterfeit because writing is acetone resistant...

--- End quote ---
EPROM counterfeits are immune to acetone by default. They remove old paint marking with solvent and apply new marking with laser. You should check if silicon die looks as it should.

ChristofferB:
I have had many issues with the tl866 and 2716 and 2732 eproms. I'm unsure if it's the chips or the burner but I've resorted to just making pinout adapters and using the lower half of a 2764

Xenon:
Yes, old topic but same problem.
My TL866II plus will not program a 2732 from Intel, TI, AMD, ST. They all fail immediately.
Tried 2764, 27128, same result.
Tried 27Cxxx and they work fine!

Seems like the current draw of the old eproms is too high.
Checked the 5V at the usb connector of the TL866, that doesn't drop below 5V.
It must have a weak internal power supply. Could not read old masked roms either, Vcc dropped to just above 3V.

Will look for another programmer, this is unusable for me as I use these old eproms most of the time.
The component test function is nice, the only reason to keep this thing from ending in the bin.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version