Author Topic: FU-Dyson-BMS - An (Unofficial) Firmware Upgrade for Dyson V6/V7 Vacuum BMS  (Read 83330 times)

0 Members and 15 Guests are viewing this topic.

Offline m0nst9ra

  • Newbie
  • Posts: 1
  • Country: ru
Hello tinfever! Thank you for helping ordinary people bring old Dyson batteries back to life. Such a question, my Dyson battery was blocked, but after disassembly it became clear that the cells were still in fairly good condition, and apparently the battery was blocked due to imbalance.
I flashed the PIC with your firmware, charged the battery, now the voltages of all cells vary in the range of 4.15-4.25V. But I ran into a problem..
The PIC does not allow startup and flashes blue 3 times, indicating that the battery is low. This is at any battery charge level.
What have I tried:
1. Replaced ISL, no changes
2. I checked all the voltages coming to the CELL terminals (ISL) 25-20.7-16.55-12.38-8.24-4.10+VBACK.
3. Checked the entire ISL binding.

--There is an interesting feature, when charging is connected, it flashes 82 times in red + blue, telling us that there is an imbalance of min-max, 82*50mV = 4.25V, so it does not see the voltage of any of the cells? I connected the oscilloscope to the AO ISL-PIC line, based on the oscillogram and firmware, no problem is visible. Maybe you have a guess what the problem is. Thank you very much!
 

Offline starfish

  • Newbie
  • Posts: 1
  • Country: ch
 :box: dyson :box:
 

Offline taiyuanshanxi

  • Newbie
  • Posts: 1
  • Country: cn
Thank you for the open source, my programmer is back, I have to try to flash the firmware of the V10 to get the V10 vacuum cleaner back, my charge equalization is mixed charging with 6 x 5v power supplies and IP3212, if the connection is not correct, it smokes and burns 2312, I have burned a few and the correct connection can charge. Thanks again to the author of V6 open source, I'm really sorry that my English level is close to zero because I didn't like to study when I was a kid, I use translation software to translate,
« Last Edit: May 30, 2024, 03:28:34 pm by taiyuanshanxi »
 

Offline rulof

  • Contributor
  • Posts: 28
  • Country: ru
Hi!  :-+

First of all my deep congratulations for all of the hard job that you did here, specially tinfever  :-+

I know it's a little "off-topic"  but I post here because I think it could be interesting,  yesterday I opened a old DC35 battery, It´s also a 6 x 18650 battery but with a different BMS MCU

- Part number at battery case 17083-22 12
- Part number at BMS board   17522 01-05


I can confirm that the MCU in this BMS board is the ATTINY44-20MU 20-QFN-EP
After reading datasheet I connected my USBasp pogrammer to:

Pin 16  MOSI
Pin 20  MISO
Pin 13  RSET
Pin 1     SCK
Pin 8    GND
Pin 9     VCC (+5V)



I succesfully downloaded Flash + Eeprom but I don´t have enough knowledge in dissassembly these files to do something interesting as tinfever did

If someone it´s interested I can upload here

Best regards
Hello, did you write about the DC35 firmware once? I'm trying to revive my battery. Did you manage to do it? If possible, send me your files.

I also counted flash and eeprom, but I don't know how to fix the eeprom to unlock it.

 

Offline Jimmy Electron

  • Newbie
  • Posts: 3
  • Country: gb
 Hi Tinfever and hat off to you and your co-conspirators for your diligent work.

 You asked for feedback to help the project.

 So, I have an SV03 pack which had stopped running for any more than 1 minute or so. Without looking into solutions, I merely renewed the 18650 cells at which point it started the 32 red flashes nonsense.
 It was at this point that the EEVblog threads and your work in particular came to my attention.


 Anyway, three months later, the SV03 is just now flashed - Although not working.

 When the trigger is pressed the motor starts and the LED's flash green, red, blue.
Then after a second or two, the motor stops and the blue LED flashes three times, This blue flash sequence repeats another three times (four in total) before going to solid green for a while, then off.

 Placing on the charger flashes yellow twice, before switching to solid blue, then green, then off.
Question, "Is it still charging whilst the LED is off?"

 Upon release of the trigger it displays six green flashes (although I am sure it was five at first).

 Measuring the battery voltage gives a reading of 23.5v


 "Is it just a question of needing to be left alone overnight to charge?"

 "At 75 - 125mV could the battery cells be too out of balance?"
 
 
 I suppose I'll see in the morning... :popcorn:
 

 
 

Offline Jimmy Electron

  • Newbie
  • Posts: 3
  • Country: gb
 Ok, an update..

 No noticeable change after several hours charging.

 Still six green or two yellow flashes depending on test, and 23.5v across the battery terminals.

 One thing that has come to light is that when I press and hold the trigger, the MAX light comes on. Then almost immediately the battery dies, until being placed back into the charger.
If the trigger is not held, as in it is 'pulsed', then the Dyson can be used for a long time witout the battery failing.

 This is leading me to consider the possibility that the main pcb has a problem.

 Not sure how easy it is to extract it but if at all possible I'll trace the circuit from the MAX button and see if perhaps a transistor has shorted and is keeping the motor at full power?
 

Offline Jimmy Electron

  • Newbie
  • Posts: 3
  • Country: gb
*Correction;

 When the trigger is pressed it flashes Red then Green - No Blue.

 Update;

 The MAX button switches between Gnd and pin 14 of a PIC16F1936 microcontroller. Therefore the idea that the MAX circuit can be easily disconnected is a non-starter as I'm quite sure that the PIC16 can't be removed and the Dyson still work.

 Shall keep trying to turn off the MAX boost feature


 Edit:-

 Turned out the MAX switch had failed with the MAX boost selected.
 Managed to switch it off by soldering a wire onto Gnd and touching it to the PIC16F1936 pin 14 whilst holding in the main power switch.

Possibly never was a battery problem in the first place, just the MAX button had failed at the wrong time.

 Fingers crossed, but all seems to be working. The LED is purple whilst on the charger....


 Edit 2;-

 Great news. The Dyson just did it's first successful house clean of the year!

 For what it's worth, there is now three yellow, and five green, flashes - But it works
 :-+
« Last Edit: July 16, 2024, 01:29:22 am by Jimmy Electron »
 

Offline Greybeard

  • Regular Contributor
  • *
  • Posts: 240
  • Country: de
Quick question:
Can I use my XGecu TL866II Plus programmer to flash the new firmware into a Dyson V6 (SV03) BMS?
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf