Author Topic: Help wanted! Sending MMS with SIM900 GSM modem...  (Read 7242 times)

0 Members and 1 Guest are viewing this topic.

Offline Slothie

  • Regular Contributor
  • *
  • Posts: 66
Help wanted! Sending MMS with SIM900 GSM modem...
« on: May 24, 2014, 01:00:26 pm »
I'm having no luck with this one. Heres what I've done:
Here's what im getting:
Code: [Select]
### sent command AT+CMEE=2
>>:
>>: AT+CMEE=2
>>:
>>: OK
### command AT+CMEE=2 finished
### sent command AT+CMMSINIT
>>: AT+CMMSINIT
>>:
>>: OK
### command AT+CMMSINIT finished
### sent command AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc"
>>: AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc"
>>:
>>: OK
### command AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc" finished
### sent command AT+CMMSCID=1
>>: AT+CMMSCID=1
>>:
>>: OK
### command AT+CMMSCID=1 finished
### sent command AT+CMMSPROTO="83.132.254.1",8080
>>: AT+CMMSPROTO="83.132.254.1",8080
>>:
>>: OK
### command AT+CMMSPROTO="83.132.254.1",8080 finished
### sent command AT+SAPBR=3,1,"CONTYPE","GPRS"
>>: AT+SAPBR=3,1,"CONTYPE","GPRS"
>>:
>>: OK
### command AT+SAPBR=3,1,"CONTYPE","GPRS" finished
### sent command AT+SAPBR=3,1,"APN","payandgo.o2.co.uk"
>>: AT+SAPBR=3,1,"APN","payandgo.o2.co.uk"
>>:
>>: OK
### command AT+SAPBR=3,1,"APN","payandgo.o2.co.uk" finished
### sent command AT+SAPBR=1,1
>>: AT+SAPBR=1,1
>>:
>>: +CME ERROR: operation not allowed
!!! UNSOLICITED RESULT CODE +CME ERROR: operation not allowed
!!! Unhandled URC: +CME ERROR: operation not allowed
### command AT+SAPBR=1,1 finished
### sent command AT+SAPBR=2,1
>>: AT+SAPBR=2,1
>>:
>>: +SAPBR: 1,3,"0.0.0.0"
!!! UNSOLICITED RESULT CODE +SAPBR: 1,3,"0.0.0.0"
!!! Unhandled URC: +SAPBR: 1,3,"0.0.0.0"
>>:
>>: OK
### command AT+SAPBR=2,1 finished
### sent command AT+CMMSEDIT=1
>>: AT+CMMSEDIT=1
>>:
>>: OK
### command AT+CMMSEDIT=1 finished
>>> AT+CMMSDOWN="PIC",42691,2000000,"test.jpg"
>>: AT+CMMSDOWN="PIC",42691,2000000,"test.jpg"
>>:
>>: CONNECT
>>:
>>: OK
### MMS down completed: OK
### sent command AT+CMMSRECP="+447775787150"
>>: AT+CMMSRECP="+44XXXXXXXXXX"
>>:
>>: OK
### command AT+CMMSRECP="+44XXXXXXXXXX" finished
### sent command AT+CMMSVIEW
>>: AT+CMMSVIEW
>>:
>>: +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
!!! UNSOLICITED RESULT CODE +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
!!! Unhandled URC: +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
>>: 1,"test.jpg",7,42691
>>:
>>: OK
### command AT+CMMSVIEW finished
### sent command AT+CMMSSEND
>>: AT+CMMSSEND
>>:
>>: +CME ERROR: The connection to network is failed
!!! UNSOLICITED RESULT CODE +CME ERROR: The connection to network is failed
!!! Unhandled URC: +CME ERROR: The connection to network is failed
### command AT+CMMSSEND finished
### sent command AT+CMMSEDIT=0
>>: AT+CMMSEDIT=0
>>:
>>: OK
### command AT+CMMSEDIT=0 finished
### sent command AT+CMMSTERM
>>: AT+CMMSTERM
>>:
>>: OK
### command AT+CMMSTERM finished
The Jpg file seems to be uploading fine, which I thought would be the hard part, but the +SABPR=1,1 command (Mysteriously referred to as "active bearer context" but otherwise undocumentede) fails with a vague "operation not allowed" message.

Then the +MMSSEND command fails, which I presume relates to the earlier failure.

Has anyone got this to work? Google has failed me on this one.
« Last Edit: May 24, 2014, 05:16:15 pm by Slothie »
 

Offline Stonent

  • Super Contributor
  • ***
  • Posts: 3824
  • Country: us
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #1 on: May 24, 2014, 01:31:50 pm »
Do text messages work? Are you registered on the network? What does at+creg? Say.
http://www.ozekisms.com/DTd/index.php?owpn=691&info=gsm-modem-connectivity/gsm-modem-debugging
« Last Edit: May 24, 2014, 01:34:26 pm by Stonent »
The larger the government, the smaller the citizen.
 

Offline Slothie

  • Regular Contributor
  • *
  • Posts: 66
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #2 on: May 24, 2014, 02:05:09 pm »
SMS was working fine last night when I tested it. Just been trying to get some more diagnostic info from it and it keeps powering down, so I think I have some hardware problem. I'll sort that out first, because its probably not been registering correctly if I have some wiring issues.

 :palm:  |O
 

Offline SL4P

  • Super Contributor
  • ***
  • Posts: 2268
  • Country: au
  • There's more value if you figure it out yourself!
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #3 on: May 24, 2014, 03:19:08 pm »
How big is your PSU, as sends can pull a bit of current.
Maybe not obvious with short SMS etc, but the longer active TX time required for MMS may sink the supply rail.
Just a thought
Don't ask a question if you aren't willing to listen to the answer.
 

Online amyk

  • Super Contributor
  • ***
  • Posts: 7871
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #4 on: May 24, 2014, 03:49:44 pm »
What's a bearer context? It's a term used in the 3GPP standards. See here and here. You don't need to read them all but you should probably famliarise yourself with the relevant standards when you want to use the technology.
 

Offline Slothie

  • Regular Contributor
  • *
  • Posts: 66
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #5 on: May 24, 2014, 05:14:50 pm »
Problem solved.

The commands I used were correct.

My power cables (to the bench supply) must be too long and skinny, because the power dipped out & disconnected the modem.

Fatter wires and some credit on the sim (*cough*) and test image arrived at my phone :)

 

Offline Slothie

  • Regular Contributor
  • *
  • Posts: 66
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #6 on: May 24, 2014, 05:20:10 pm »
How big is your PSU, as sends can pull a bit of current.
Maybe not obvious with short SMS etc, but the longer active TX time required for MMS may sink the supply rail.
Just a thought

Spot on. 470uF electrolytic & some fat wires stopped the problems.
 

Offline Mukhtarkarim

  • Contributor
  • Posts: 9
  • Country: pk
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #7 on: October 12, 2015, 12:59:38 pm »
i want to send an image as multimedia message to my mobile cell using SIM900.is it possible.as the image is stored in an sd card.plz any one halp me......... :( O0
 

Offline Mukhtarkarim

  • Contributor
  • Posts: 9
  • Country: pk
Re: Help wanted! Sending MMS with SIM900 GSM modem...
« Reply #8 on: October 12, 2015, 01:41:55 pm »
I'm having no luck with this one. Heres what I've done:
Here's what im getting:
Code: [Select]
### sent command AT+CMEE=2
>>:
>>: AT+CMEE=2
>>:
>>: OK
### command AT+CMEE=2 finished
### sent command AT+CMMSINIT
>>: AT+CMMSINIT
>>:
>>: OK
### command AT+CMMSINIT finished
### sent command AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc"
>>: AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc"
>>:
>>: OK
### command AT+CMMSCURL="mmsc-ac.mms.o2.co.uk:10021/mmsc" finished
### sent command AT+CMMSCID=1
>>: AT+CMMSCID=1
>>:
>>: OK
### command AT+CMMSCID=1 finished
### sent command AT+CMMSPROTO="83.132.254.1",8080
>>: AT+CMMSPROTO="83.132.254.1",8080
>>:
>>: OK
### command AT+CMMSPROTO="83.132.254.1",8080 finished
### sent command AT+SAPBR=3,1,"CONTYPE","GPRS"
>>: AT+SAPBR=3,1,"CONTYPE","GPRS"
>>:
>>: OK
### command AT+SAPBR=3,1,"CONTYPE","GPRS" finished
### sent command AT+SAPBR=3,1,"APN","payandgo.o2.co.uk"
>>: AT+SAPBR=3,1,"APN","payandgo.o2.co.uk"
>>:
>>: OK
### command AT+SAPBR=3,1,"APN","payandgo.o2.co.uk" finished
### sent command AT+SAPBR=1,1
>>: AT+SAPBR=1,1
>>:
>>: +CME ERROR: operation not allowed
!!! UNSOLICITED RESULT CODE +CME ERROR: operation not allowed
!!! Unhandled URC: +CME ERROR: operation not allowed
### command AT+SAPBR=1,1 finished
### sent command AT+SAPBR=2,1
>>: AT+SAPBR=2,1
>>:
>>: +SAPBR: 1,3,"0.0.0.0"
!!! UNSOLICITED RESULT CODE +SAPBR: 1,3,"0.0.0.0"
!!! Unhandled URC: +SAPBR: 1,3,"0.0.0.0"
>>:
>>: OK
### command AT+SAPBR=2,1 finished
### sent command AT+CMMSEDIT=1
>>: AT+CMMSEDIT=1
>>:
>>: OK
### command AT+CMMSEDIT=1 finished
>>> AT+CMMSDOWN="PIC",42691,2000000,"test.jpg"
>>: AT+CMMSDOWN="PIC",42691,2000000,"test.jpg"
>>:
>>: CONNECT
>>:
>>: OK
### MMS down completed: OK
### sent command AT+CMMSRECP="+447775787150"
>>: AT+CMMSRECP="+44XXXXXXXXXX"
>>:
>>: OK
### command AT+CMMSRECP="+44XXXXXXXXXX" finished
### sent command AT+CMMSVIEW
>>: AT+CMMSVIEW
>>:
>>: +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
!!! UNSOLICITED RESULT CODE +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
!!! Unhandled URC: +CMMSVIEW: 2,"","+44XXXXXXXXXX","","","2000-01-01,00:00:54","",42730
>>: 1,"test.jpg",7,42691
>>:
>>: OK
### command AT+CMMSVIEW finished
### sent command AT+CMMSSEND
>>: AT+CMMSSEND
>>:
>>: +CME ERROR: The connection to network is failed
!!! UNSOLICITED RESULT CODE +CME ERROR: The connection to network is failed
!!! Unhandled URC: +CME ERROR: The connection to network is failed
### command AT+CMMSSEND finished
### sent command AT+CMMSEDIT=0
>>: AT+CMMSEDIT=0
>>:
>>: OK
### command AT+CMMSEDIT=0 finished
### sent command AT+CMMSTERM
>>: AT+CMMSTERM
>>:
>>: OK
### command AT+CMMSTERM finished
The Jpg file seems to be uploading fine, which I thought would be the hard part, but the +SABPR=1,1 command (Mysteriously referred to as "active bearer context" but otherwise undocumentede) fails with a vague "operation not allowed" message.

Then the +MMSSEND command fails, which I presume relates to the earlier failure.

Has anyone got this to work? Google has failed me on this one.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf