Author Topic: Pop and thump sound coming in through speaker when turning the class D ON  (Read 929 times)

0 Members and 1 Guest are viewing this topic.

Offline tapasxplore

  • Contributor
  • Posts: 21
  • Country: in
Hi,

I am using TPA2005D1 class D amplifier IC, whenever I am turning ON the IC, while the volume is set to high, it is making loud thump and pop sound, then it goes away and works fine. But while the volume is set to low and then I turn ON the device, then is no thump and pop sound.

The line level input that I am giving to TPA2005D1 contains small DC offset, but I am using coupling capacitor to make offset zero. (Please find the schematic attached below)

 

Offline Zero999

  • Super Contributor
  • ***
  • Posts: 13109
  • Country: gb
  • 0999
Don't set the volume too high then: problem solved!

This is quite common with any audio amplifier, due to the AC coupling capacitors charging up, during power on. You could delay the start up of the amplifier by adding an RC circuit to the shutdown pin, although you might need a Schmitt trigger after (e.g. 74HC1G14) it, to ensure stability.

I notice there's no decoupling on the VDD line: add a 1000µF capacitor in parallel with 100nF, as close to the power pins as possible.
« Last Edit: April 04, 2018, 03:04:23 pm by Hero999 »
 

Offline Brumby

  • Supporter
  • ****
  • Posts: 9307
  • Country: au
Some high power amplifiers have relays which disconnect the speakers during the first few seconds after power-up.  This works very well for fixed sound reinforcement installations with set microphones.

I designed a system a couple of decades ago that had several fixed microphones and others that were plugged in as required.  The people using this system were not technical in any sense and giving them basic microphone training was a challenge for some.  The mixer was preset and locked for normal use, but an operator could run it live, if they were sufficiently competent.

For normal use, the rules were simple: Plug in all the microphones required and then turn on the system.  In my testing, I would flick on the switch and duck out to a nearby speaker just in time to hear a short period of silence followed by the system becoming active - and a lowly cricket somewhere near a microphone came through clearly ... without any disruptive transients of any kind.
 

Offline tapasxplore

  • Contributor
  • Posts: 21
  • Country: in
Hi,

Method 1:
Can we connect 100K resistor between C15 and ground ; 100K between C16 and ground, so that there is no buildup of charge in the capacitor as to reduce the pop sound in the first place.

Method 2:

We can delay the start of the TPA2005D1 using RC circuit in the shutdown pin, so that pop sound will be eliminated.

Should I start with method 1 or method2 ?

-Tapas

 

Offline Zero999

  • Super Contributor
  • ***
  • Posts: 13109
  • Country: gb
  • 0999
Hi,

Method 1:
Can we connect 100K resistor between C15 and ground ; 100K between C16 and ground, so that there is no buildup of charge in the capacitor as to reduce the pop sound in the first place.
How would that help?

Quote
Method 2:

We can delay the start of the TPA2005D1 using RC circuit in the shutdown pin, so that pop sound will be eliminated.

Should I start with method 1 or method2 ?

-Tapas


Read my previous post.
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf