Electronics > Projects, Designs, and Technical Stuff

TL866II Plus with Macronix (MXIC) MX25L12873F

(1/2) > >>

EGGMAN2112:
Hmm.. I read through quite a few threads but I don't see this chip mentioned specifically.

Normally I can read and write Winbond chips with no problems.

Now I have this Macronix MX25L12873F and it was reading with no problems with TL866II Plus and seems to write with no problem but then fails the verify right away.

I am pretty sure this is just something simple but I have to find out somehow.

I have attached photo and logs and maybe someone knows this write away....

Also there are 6 types of MX25L12873F listed in the Xgpro 10.90 Software. Its obviously not a SOP16 but I don't know if there's a difference between SOP8, WSON8, OTP SOP8, OTP WSON8.

Anyway I hope someone can help out!  :popcorn:

BrokenYugo:
Doesn't "OTP" stand for "one time programable"? You aren't going to be able to write to it if it's write protected.

TomS_:
WSON are "wafer scale" I believe, basically a bare silicon die with solder balls like a BGA.

SOP is very similar to SOIC but slightly larger (wider) body and pin spacing.

I'm surprised if there is a OTP version of these chips since 25 series are flash, so most definitely EE devices - unless they are made from chips where the erase circuitry fails during production. :shrug:

EGGMAN2112:
Thank you all. I have researched more - it's definitely not OTP. It's not WSON so that leaves SOP8.

BTW This is HP Elitebook 840 G2 and I have done lots and lots of these with Winbond chips still on the board with no problems.

Now I run into these Macronix chips and they just don't program the same.

So I read the chip, removed the password, now it fails verify when writing back. Many are saying to remove the chip from the board for programming but I am not 100% sure that's necessary.

I thought the laptop was bricked but then I used the HP USB Bios recovery (WIN+B) and it reprogrammed the BIOS and booted up - however it has the dreaded "Warning!! Machine is not in committed state!"

So I am getting somewhere - now I have all the DMI tools but those don't work unless the MPM is in an unlocked state. Many are saying you have to re-flash with a clean ME to get rid of that and unlocking the MPM requires SMC blob which is not obtainable.

I guess its getting closer to having to remove the chip from the system board but I would like to avoid that at all cost. AS well HP has decided to change their policy about removing any BIOS passwords now even under warranty so its reprogram or scrap it as all boot options locked to UEFI network boot - go figure.

So should I attempt chip removal or keep trying to fix the vpro amt committed state?

narkeleptk:
Remove the chip from board and your problem will be solved.

Navigation

[0] Message Index

[#] Next page

There was an error while thanking
Thanking...
Go to full version