Electronics > Power/Renewable Energy/EV's

UCC28019 based PFC blows up the mosfet

<< < (4/4)

Ashwin619:
I have just tested the circuit again, this time without any input series bulb and with input MCB just for safety and it has suddenly started working ;D. Here's the video of its working,
https://drive.google.com/file/d/1I9rDiz45V3ZBMv3ARzVjqG3qoo4sPfiA/view?usp=sharing

The output voltage in the video is low due to some error in the output reference, after adjusting it I am getting the desired voltage of around 370V. The mosfet (currently without any heatsink) and the inductor seem to heat to quite some extent. I believe the high Rds on of the mosfet i.e. IRF840 (~0.8 Ohm) and a possible case of inductor saturating might be the culprits behind it. Probing the inductor current waveform via Rsense as suggested by TimNJ may help to shed some light on it.

Nevertheless, I appreciate the help and suggestions provided by you guys. I Will let you know once I apply some different loads across it.

Thanks and Regards,
Ashwin619.

Ashwin619:
Hello everyone,

So today I tried testing the circuit again along with the measuring of the inductor current waveform (via DSO probes across the Rsense). I have also changed the mosfet (with a heatsink) from IRF840 to FCP190N65 which is rated for almost 600V and has a better Rdson value.

The inductor still heat's to quite an extent (if kept operating for more than a couple of minutes). There are quite some spikes on the inductor voltage waveform (at an input close to 120Vac), which decreases as we approach higher voltage (~ 180 - 220 Vac). This perhaps indicates some momentary saturation during turn ON and turn OFF of the mosfet. The current waveform doesn't clearly show any sign of saturation but maybe that's dues to the bigger timescale and poor resolution of the red DSO kit.

The power levels I have measured are as follows,
Vin = 160 Vac, Iin ~ 0.6 A
Vout = 371.6 Vdc, Iout ~ 0.25 A
Efficiency ~ 96.7%

The currents were measured using a clamp meter and all the values are in RMS. I hope this calculation makes any sense.

The heating of the inductor is something that I am worried about as it seems somewhat abnormal.

Please let me know if there's any solution to this other than beefing up the inductor.
 


Navigation

[0] Message Index

[*] Previous page

There was an error while thanking
Thanking...
Go to full version