Author Topic: [Solved] Board U11150 Acova Timerprog repair  (Read 223 times)

0 Members and 1 Guest are viewing this topic.

Offline ghorizo

  • Contributor
  • Posts: 9
  • Country: fr
[Solved] Board U11150 Acova Timerprog repair
« on: January 15, 2020, 06:54:42 pm »
Hello I wanted to try and repair this little control board from the bathroom heater.
When powered it gives no signs of life: leds are off and so is the relay. The main resistance measured 62 ohms.
I can see no visibly damaged components for which I hope for as that is about my level. I have tried following the live circuit but get lost quite quickly and don't feel so confident about doing, but still I would really like to understand the diagnosis process as I'm constantly around broken electronics.

Could someone please help me go through this?

« Last Edit: January 16, 2020, 04:23:33 pm by ghorizo »
 

Offline fzabkar

  • Frequent Contributor
  • **
  • Posts: 628
  • Country: au
Re: Board U11150 Acova Timerprog repair
« Reply #1 on: January 16, 2020, 02:22:00 am »
I would start by desoldering and reflowing each of the corroded solder joints (there are many).

Then I would measure the voltage across each of the capacitors. One will probably be the coil voltage for the relay, while the other will probably be the Vcc voltage for the NEC microcontroller IC.

Be very careful. You are working with a live circuit.
 

Offline ghorizo

  • Contributor
  • Posts: 9
  • Country: fr
Re: Board U11150 Acova Timerprog repair
« Reply #2 on: January 16, 2020, 08:29:07 am »
So I have re-soldered all the trough hole joints and the more accessible smds.
Measured voltae across the electrolytic caps is 3.10 and 3.15 volts dc. On the film one I get varying measurements in the mV range, could it be it the culprit? But when removed  from the circuit it measures up to spec so maybe no.


Update:
So after that all the components measured seemed fine I thought of looking for the installation manual from the manufactgurer's website.
Turns out whoever got into this before me swapped some wires around so it was installed wrong (lucky the owner was convinced it was working before!). What I marked as earth and had quite a few suspicions about turns out to be neutral, and there is no earth but a control wire to remotely control the unit.
So here it ends quite stupidly from not reading ahead, hey at least I cleaned up the corroded joints.

Thanks anyway fzabkar I appreciate the help!
« Last Edit: January 16, 2020, 04:21:50 pm by ghorizo »
 


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf