Electronics > Repair

After replacing Tek2440 Ram U664 and U350 by FRAM no scope display anymore

(1/8) > >>

I hoped that I still could self diag and externally calibrate my oscilloscope like they tell it is easy and only about 2 pages in the service manual.
Sadly after replacing the troubled old 32K SRAMs by 28 pin FRAMs FM1808 my scope no longer reacts on any of the buttons and no longer gives any display READOUT text messages anymore.
And copying both SRAMs failed so not what I hoped or expected. Is there any way to restore and calibrate my 2440 scope without using the external Gpib bus? Or does anyone made a copy of a working SRAM chip that I can use to at least use my scope again? I already removed jumper J156 but it made no useful difference.

David Hess:
Losing the battery backed up SRAM data will not stop a 2440 series DSO from operating.  I hope you installed sockets instead of the FRAMs directly.

I have the same model, same problem.  The scope has been bricked.  I replaced both NVRAMs and now, nonsense display, no response to controls.

Have you tried putting the original SRAMs back in place? I've tried using FRAM to replace NVRAM in several different devices and it hasn't worked in any of them. The issue comes down to a quirk in the way the address is latched or something like that, IIRC the enable line has to go inactive between each write. If you had access to the source code it would be easy to modify an existing device to work with FRAM but without that whether it works is a matter of luck in how it was designed.

I put one NVRAM back in but the other got broken.  No change in performance.


[0] Message Index

[#] Next page

There was an error while thanking
Go to full version